1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Content View single item URL

Content View single item URL

5 posts, 0 answered
  1. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    03 Oct 2008
    Link to this post
    hey guys!

    i have just written a class library (and the associated templates) which extend the Content View control. The list side of things works as desired (i.e. in that it displays the correct items!). however the hyperlinks to each individual item do not work for some reason.

    i first assumed that this was down to my own wrong doing. so to rule this out i deleted my control and put in a standard content view. the items get listed as expected, but once again the URLs are invalid.

    i wish the URLs to mirror the content item's name, and so i checked the web config to find that this was the bahviour that had been defined anyway!

    i hope you can help with this , or offer some kind of advice, many thanks!

    Nick
  2. Joe
    Joe avatar
    138 posts
    Registered:
    24 Sep 2012
    03 Oct 2008
    Link to this post
    Hi Nick,

    Thanks for contacting us.

    Where are the hyperlinks taking you and what is their end result? What are the hyperlinks supposed to look like? For example, if the hyperlink is supposed to say www.yahoo.com, is it saying something like www.yahoo.com/12333? Could we see your code sample, so we can better understand what you are trying to achieve?

    Sincerely yours,
    Joe
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    03 Oct 2008
    Link to this post
    i can't post my code currently as i am no longer in my office. however i don't believe the problem originates with my code specifically as the problem exists if i use a standard Content View also.

    the page housing this control is at a url: www.website.com/page-with-control
    i would like the generic content items to be displayed at www.website.com/page-with-control/[generic content name] (a page does not exist at this url, but i hoped it would work like news view where one page operats as both list and single item display)

    the hyperlink that the content view prints matches the above format for the URL, but i get a page not found error when the link is followed.

    the actual code that my content view extension uses follows the example found here: http://www.sitefinity.com/help/developer-manual/extending-built-in-controls-content-view-control.html

    hope this helps,
    Nick
  4. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    06 Oct 2008
    Link to this post
    i have now resolved this problem, so it can be ignored. the problem was because i was viewing the control in a preview in a page that had not been published! As soon as i sent the page in question through workflow it worked as expected!

    it's always the simplest problems that take the longest to reach a solution!
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    06 Oct 2008
    Link to this post
    Hi Nick,

    Thank you for following up! It's good to know that everything is fine.
    Greetings from the team!

    Best wishes,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
5 posts, 0 answered