1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Create new project

Create new project

5 posts, 0 answered
  1. Primoz
    Primoz avatar
    3 posts
    Registered:
    23 Mar 2009
    23 Mar 2009
    Link to this post
    Hi,

    I've successfully installed the Sitefinity 3.6 standard pack locally on my Vista Business (32bit) with IIS7.

    When I try to create a new project, I get the following message:
    "The account, you have authenticated with, has no permissions to create virtual directories. Please make sure that windows authentication is enabled."

    The Windows Authentication in IIS Manager for the user is enabled.

    Did I miss something out?

    Thanks in advance.

    Regards,

    Primoz

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    23 Mar 2009
    Link to this post
    Hi Primoz,

    Take a look at the following trouble shooting article http://www.sitefinity.com/sf3/troubleshooting.html#12. Let us know if the problem persists.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. Primoz
    Primoz avatar
    3 posts
    Registered:
    23 Mar 2009
    23 Mar 2009
    Link to this post
    I set the following security settings for the Sitefinity3.6 virtual folder:
    1. 1. Anonymous Authentication is disabled.
    2. 2. ASP.NET Impersonation is enabled.
    3. 3. Forms Authentication is disabled.
    4. 4. Windows Authentication is enabled.
    5. 5. Restart Server.

    I also ran IE with Administrator rights as suggested by Ivan.

    The same symptom occured.

    It seems the user, in my case "User: melack-PC\melack" does not have permissions for creating a folder in "C:\Program Files\telerik\Sitefinity3.6\WebSites", although I am the administrator.

    Any ideas?

    Regards,

    Primoz

  4. Primoz
    Primoz avatar
    3 posts
    Registered:
    23 Mar 2009
    23 Mar 2009
    Link to this post
    I gave it another try and uninstalled the Sitefinity 3.6. Also I have deleted the C:\Program Files\telerik\Sitefinity3.6\*.* folder, to have a clean starting point.

    My procedure was as follows:

    1. Run Sitefinity 3.6 standard installation pack as Administrator and install it.

    2. Open IIS Manager.

    3. Select Application Pools. Change the Managed Pipeline Mode property in DefaultAppPool from Integrated to Classic.

    4. Next in the Connections pane select "Sites-> Default Web Site->telerik->Sitefinity3.6". In "Features View" under IIS select "Authentication" and set the following parameters to:

    Anonymous Authentication:  Disabled
    ASP.NET Impersonation: Enabled
    Forms Authentication: Disabled
    Windows Authentication: Enabled

    4. Go to "Sites-> Default Web Site->telerik->Sitefinity3.6" Features View" again.

    5. In the right pane (Actions) select the "Basic settings..." and click "Connect as...". Specific user should be selected by default, click "Set". Add a username and password which should be the same as the user account in Windows Vista.

    6. Open a browser and type  http://localhost/telerik/Sitefinity3.6.

    7. It will ask you for a username and password (this is the same as the one you just created in step 5.)


    Hope this helps. It worked for me.

    Regards,

    Primoz
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    24 Mar 2009
    Link to this post
    Hello Primoz,

    Thank you for sharing your steps with us. Just to let you know you can run the website in Classic and Integrated mode as well. Another option is installing Sitefinity directly from Visual Studio.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Register for webinar
5 posts, 0 answered