1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / CSS missing with some extensionless URLs

CSS missing with some extensionless URLs

2 posts, 0 answered
  1. Kevin
    Kevin avatar
    42 posts
    Registered:
    15 Mar 2005
    04 Nov 2009
    Link to this post
    I'e been trying to get extensionless URLs working, and have had some success.  For example, the two following pages render correctly:

    http://sitename/Components/ARM.aspx
    http://sitename/Components/ARM

    But when I have a trailing "/" the CSS is completely missing and the page layout is completely destroyed, for example:

    http://sitename/Components/ARM/

    I can't really see any obvious difference, but are you aware of any way to work around this, since I think it's reasonable to expect users to 'guess' certain urls and there's a 50% chance they'll leave a trailing slash

    Kevin.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    04 Nov 2009
    Link to this post
    Hi Kevin,

    When you place a slash at the end of the URL, the actual path is changed. Additional slash means one level down. Despite that, this should be working in Sitefinity just as you expect it. Can you please let us know which is the version that you are running? 

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
2 posts, 0 answered