1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Debugging in Visual Studio

Debugging in Visual Studio

2 posts, 0 answered
  1. Pamela Thalacker
    Pamela Thalacker avatar
    14 posts
    Registered:
    25 Feb 2010
    02 Mar 2010
    Link to this post
    I have numerous posts discussing breakpoints and debugging, but I can't seem to make it work.  If I highlight the web site root and click F5, I get a folder listing of the root folder in the browser.  I am not able to find an entry point to the application.  I have IIS setup with my Sitefinity application in the Default Web Site as instructed and it runs properly, but the developer web server used by Visual Studio doesn't seem to be able to access the web site properly.

    There must be something more to getting this to work.  What am I missing?

    Pamela
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    02 Mar 2010
    Link to this post
    Hi Pamela Thalacker,

    You can take a look at this articles

    Debugging in Visual Studio
    Using the Debugger
    Debugging ASP.NET Web Applications

    The IIS process use w3wp.exe worker process. So you need to attach the debugger to w3wp.exe

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
2 posts, 0 answered