+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Duplicate Page Workflow

Duplicate Page Workflow

4 posts, 0 answered
  1. mcpdinkansas
    mcpdinkansas avatar
    102 posts
    Registered:
    22 Mar 2007
    04 Nov 2011
    Link to this post
    We have discovered an issue and we were wondering if there was any fix for it. The duplicate page process seems to not follow the appropriate workflow settings.

    If you have workflow turned on and you create a new page, until that page has been "published" you get a "This page is under construction" error when trying to access the page through the public site.

    If you duplicate a page, that page is immediately available through the public site before you ever "publish" it. We would like for the duplicate page to follow the same process that the create new page uses.

    Can you confirm you can replicate this issue? If so, is there a fix or workaround for this?

    Thanks
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    08 Nov 2011
    Link to this post
    Hi Mcpdinkansas,

    Can you please let us know if you are using Sitefinity 3.7 SP4? In this version when you duplicate a page you will allow you to save it to draft and you cannot publish the page directly without going to the workflow process. Also the page will not be visible in navigation until you publish it.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. mcpdinkansas
    mcpdinkansas avatar
    102 posts
    Registered:
    22 Mar 2007
    08 Nov 2011
    Link to this post
    We are currently running 3.7.2057.2:1. Will updating to SP4 resolve this problem?
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    08 Nov 2011
    Link to this post
    Hi Mcpdinkansas,

    Upgrading should resolve the problem. However you can first test this on a blank Sitefinity 3.7 SP4 project. You can find upgrade instructions here.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered