+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Extensionless URLs

Extensionless URLs

16 posts, 0 answered
  1. Andrew
    Andrew avatar
    6 posts
    Registered:
    26 Jul 2007
    26 Jul 2007
    Link to this post
    Hello

    I've been having a quick look at Sitefinity today with a view to replacing our current CMS (Kentico. Would be lovely if it weren't so darned buggy!)

    The main concern I have is that I cannot see if it is possible to use the url re-writer to create pages with no file extension.

    For example with kentico I can create a page with a url such as
    http://somedomain.com/pressreleases/companymerger
    rather than the
    http://somedomain.com/pressreleases/companymerger.aspx which most CMS' seem to require

    Is this possible with sitefinity?
  2. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    27 Jul 2007
    Link to this post
    Hello Andrew,

    Sitefinity supports extensionless URLs, once you set a wildcard mapping in the IIS.

    In IIS version 5.x you can do this by adding a new application map:
    1. from your project click Properties, go to the virtual folder tab and click Configuration
    2. in the executable textbox place the path to the aspnet_isapi.dll
    3. in the extension textbox you must specify the ".*" to specify all kinds of extension.

    Also make sure that the "Check that file exist" checkbox is unchecked. In IIS 6 you will only need to specify the path to the aspnet_isapi.dll executable through the wildcard application maps list.

    Also, except wildcard mapping, we support a better approach for extensionless URLs, because wildcard mapping makes each and every request go through ASP.NET 2.0 ISAPI handler including urls with .gif, .css, .js, .html etc. So, it cause performance sacrifice. This approach handles HTTP 404  (when you request extensionless URL, you get HTTP 404). To use it in Sitefinity change 404 default page to the path to the .aspx page with name sf404.aspx in your site and the Type to "URL": 

    On IIS 5.x/6.x:


    On IIS 7.0, change 404 default page to /sf404.aspx and the type to "ExecuteURL". Also, change the default error response to "Custom error pages".
    Sitefinity handles request to sf404.aspx page and rewrites path to the required URL.

    Unfortunately, the second approach is not working correctly when the application is set as Web Site in current official release of Sitefinity, you can use it only with virtual directories. We already fixed this issue and it will be abailable in the next release.

    Hope this helps.

    Kind regards,
    Vlad
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Andrew
    Andrew avatar
    6 posts
    Registered:
    26 Jul 2007
    27 Jul 2007
    Link to this post
    Thanks!
  4. Allen DeLaney
    Allen DeLaney avatar
    1 posts
    Registered:
    21 Apr 2006
    03 Aug 2007
    Link to this post
    Is this solution only available in the full version?  I have tried this in the Community version (3.0 sp2) with IIS 5.1 and I simply get "The resource cannot be found".
  5. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    03 Aug 2007
    Link to this post
    Hi Allen,

    There should not be a problem with the Community version. You only need to make the appropriate settings in the IIS. Which of the solutions did you try? Maybe you are confused by the fact that it is not mentioned in this thread that these solutions refer only to Page Groups. Only for Page groups extensionless URLs make sense.

    Don’t hesitate to ask if you come up with more questions.

    Greetings,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Mike
    Mike avatar
    22 posts
    Registered:
    05 Mar 2008
    28 Apr 2008
    Link to this post
    Would anyone please tell me where this wonderfully magical sf404.aspx page actually is? if i follow the user manual instructions TO THE LETTER for IIS 5.1. I get the same default 404 error 

    The page cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Please try the following:

    • If you typed the page address in the Address bar, make sure that it is spelled correctly.
    • Open the localhost home page, and then look for links to the information you want.
    • Click the Back button to try another link.

    HTTP 404 - File not found
    Internet Information Services


    Technical Information (for support personnel)


    i simply want to be able to type in www.mysite.com/services  and have it default me to the first child page in its Page Group, as it should by all accounts of the user manual and how the site is configured. 

    Frustratingly,
    Mike
  7. Nikifor
    Nikifor avatar
    232 posts
    Registered:
    18 May 2013
    29 Apr 2008
    Link to this post
    Hi Mike,

    A known issue for Sitefinity 3.2 SP1 release is related to adding a sf404.aspx error page through the IIS configuration. Nevertheless, you can use another approach. Please, follow the steps for adding the wildcard mapping from the User Manual section Wildcard Application Mappings. This is how you will be able to access the desired page when you make request to www.mysite.com/services.

    Hope this helps. Do not hesitate to contact us if you have any other questions.

    Kind regards,
    Nikifor
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. Mike
    Mike avatar
    22 posts
    Registered:
    05 Mar 2008
    29 Apr 2008
    Link to this post
    Thanks for the response.

    The Wildcard Mapping suggestion is just not practical, effective, or even useable at any level. I say this for the simple fact that my homepage prior to making the suggested change loaded in under a second, and as of right now it has been over 300 SECONDS and the page has yet to load. If i remove the wildcard, the site loads back under the 1 second mark.

    I did this same suggestion on the TIU sample site with the same results.

    anyone else have any suggestions and/or workarounds?

    TIA,
    Mike
  9. Marlon Walcott
    Marlon Walcott avatar
    13 posts
    Registered:
    31 Oct 2006
    30 Apr 2008
    Link to this post
    My suggestion to the Telerik Team is to fix al lthe bugs you currently have and trust me there are a couple, rather than creating new modules and in effect having more bugs. Perfect the version you have now please and remove the bugs. If you do this I think that all your customer would appreciate it.

    I have one big problem right now and that is, after upgrading to Version 3.2 SP1 (used the BlankProject), I am constantly getting 404 errors for pages which exist. When I restart  IIS, the pages come up back but soon thereafter the pages will go back to showing 404 error again. Can you please address this issue for me in a timely manner?

    Thank you in advance (and please take my advice into consideration)
  10. Bob
    Bob avatar
    330 posts
    Registered:
    24 Sep 2012
    01 May 2008
    Link to this post
    Hi Marlon Walcott,

    Thank you for your advice. In fact this is exactly what we are doing now. We are going to postpone all new modules and features until we clear all known issues. Also soon we will provide public bug tracking system so that everyone will be able to track the status of known bugs.

    About your problem, you are the first to report such behavior. Does it happen to random pages, always to particular pages or all pages? Could you send us your project and database along with steps to reproduce this problem? We need to debug in order to find what is causing it.


    Sincerely yours,
    Bob
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  11. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    11 May 2009
    Link to this post
                
  12. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    11 May 2009
    Link to this post
    Hello James,

    Thank you for taking part of this discussion. I am not sure if you have a problem with the Extensionless URLs though.

    I have checked your account, and it seems you are evaluating Sitefinity for around a week. You do not have any support tickets sent, or forum threads excepting the SQL Server configuration problems.

    We will appreciate a constructive feedback. If you are willing to open forum/support threads for the issues you experience with Sitefinity, we would love to provide you with answers as soon as possible.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  13. Stuart Radlett
    Stuart Radlett avatar
    12 posts
    Registered:
    13 Feb 2009
    27 May 2010
    Link to this post
    I've tried this method and get ".*" with and without the quotes as invalid file extension. The sf404.aspx page method also doesn't work for SF3.7
  14. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    27 May 2010
    Link to this post
    Hello Stuart Radlett,

    Both methods work for the latest version of Sitefinity. I have attached sample settings for either of them. You can also try to remove the page extension from web.config:
    <cms defaultProvider="Sitefinity" pageExtension="" siteTemplate="" projectName="Extensions" disabled="false" pageEditorUIMode="Overlay">


    All the best,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  15. Nick
    Nick avatar
    2 posts
    Registered:
    23 Jan 2012
    22 Mar 2012
    Link to this post
    I'm having this issue as well and added the ".*" to the extensions.  That works however I get the 404 and the only way around that is to add a trailing slash.  The next issue is that not everything works now, I get "The resource cannot be found." and I'm assuming more trailing slashes are missing in the JavaScript.  What is the fix to this?  I'm running IIS 5.1 on my local machine and SiteFinity 4.4.
  16. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    26 Mar 2012
    Link to this post
    Hello Nick,

    Officially Sitefinity does not support IIS 5.1. We support IIS 6.0 and IIS 7+. It is recommended that you run the website on IIS 7.0 or IIS 7.5 integrated pipeline mode. If you do not have those versions of IIS on your development machine (e.g. if you are running Windows XP) it is recommended that you either use the embedded web development server of the Sitefinity Project Manager or the one embedded in Visual Studio 2010.

    The problem with IIS 5.1 is that it is not designed to support extensionless URLs natively. This support comes with .NET framework 4.0 and IIS 7.x. Unfortunately the only way to remove the obstacle is to use URL redirecting module to redirect urls without the trailing slash to ones with a trailing slash.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
16 posts, 0 answered