+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Extensionless URLs in Sitefinity 3.7 for IIS7

Extensionless URLs in Sitefinity 3.7 for IIS7

11 posts, 0 answered
  1. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    25 Feb 2011
    Link to this post
    Hi Guys,

    I found this article you guys wrote on extensionless URLs for IIS6:
    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/developing-with-sitefinity/extensionless-urls.aspx


    Could someone please send me the same information but for SF 3.7 in IIS7 please?

    Many thanks!
  2. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    28 Feb 2011
    Link to this post
    Hi Guys,

    Any joy with this one?

    Thanks
  3. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Mar 2011
    Link to this post
    Hi James@Nw,

    In IIS 7.0 you should not use sf404 error page. Instead you should go to the Handler Mappings section of your website in IIS and create a new Wilcard Script Mapping. You should use the aspnet_isapi.dll as the executable to map to. Then you can go to the <cms> configuration section and set the pageExtension property to empy string ("").

    All the best,
    Radoslav Georgiev
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
  4. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    01 Mar 2011
    Link to this post
    Hi Radoslav,

    Thanks for getting back to me on this. I have followed your instructions but got no joy out of it. I have attached a screenshot to show you what I mean along with the error message I get.

    HTTP Error 404.0 - Not Found

    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.



    Thanks!
    James
  5. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Mar 2011
    Link to this post
    Hello James@Nw,

    From the attached image I can see that you are referencing the ASP.NET 4.0 version of the aspnet_isapi.dll. Is it possible that your website is not running on .NET 4.0? If yes you should reference the proper .NET version of the aspnet_isapi.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
  6. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    01 Mar 2011
    Link to this post
    Hi Radoslav,

    Thanks once again for getting back to me on this.

    I've looked and only found that DLL in version 2.0.5 of the .Net Framework, so I am assuming this is the one that I should use? (it doesn't appear in Version 3.5)

    I've tried this option and it still returns a 404 error

    Thanks,
    James
  7. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    01 Mar 2011
    Link to this post
    Hi Radoslav,

    Any other suggestion on this one please?

    Thanks,
    James
  8. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    03 Mar 2011
    Link to this post
    Hi Radoslav,

    Anything else on this?

    Cheers,
    James
  9. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    04 Mar 2011
    Link to this post
    Hi Radoslav,

    On this page: http://www.sitefinity.com/devnet/forums/sitefinity-3-x/developing-with-sitefinity/extensionless-urls-in-sitefinity-3-6.aspx

    You refer to integrated or classic mode of IIS.

    Is there not something we need to do like this in IIS7?

    Thanks,
    James
  10. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    04 Mar 2011
    Link to this post
    Hello James@Nw,

    The wildcard handler mapping method should work for both classic and integrated mode. Please take a look at this post.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
  11. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    09 Mar 2011
    Link to this post
    Hi Radoslav,

    For the extensionless URLS to work, do we have to use Virtual Directories as in this image? http://www.sitefinity.com/ClientsFiles/195967_isapiwildcard.png

    You mention on this post:

    On IIS 7.0, change 404 default page to /sf404.aspx and the type to "ExecuteURL". Also, change the default error response to "Custom error pages".
    Sitefinity handles request to sf404.aspx page and rewrites path to the required URL.

    Unfortunately, the second approach is not working correctly when the application is set as Web Site in current official release of Sitefinity, you can use it only with virtual directories. We already fixed this issue and it will be abailable in the next release.

    Has this been fixed since? I think this may be the reason I am not able to get this right.

    Please let me know.

    Cheers,
    James
Register for webinar
11 posts, 0 answered