1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Files Viewer with Private Folder

Files Viewer with Private Folder

4 posts, 0 answered
  1. Allen
    Allen avatar
    71 posts
    Registered:
    04 Aug 2007
    15 Jan 2008
    Link to this post
    I have the SiteFinity application running for a client, copied to their inetpub/wwwroot/ directory.  Everything is working fine except they have requested that I add a WSS instance to the server in the same directory as well.  In tests, everything works fine except that the Files module throws an error (no file permission), which is what I want - no permission.  However, I cannot find a way to exclude the Files page/control from trying to examine this subfolder.  Is there a way to do that?  If not, is there a way to give the control read-only access to this path? (I tried giving the ASPNET and IUSR_xxxx read permission, but this didn't seem to work either).


    Thanks
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    15 Jan 2008
    Link to this post
    Hello Allen,

    I am not sure if I understand you correctly. Do you want to restrict user access to a given folder in Files?

    Currently, the only way to manage Files permissions is from Administration -> Permissions -> Manage files. You can select a given role and allow or deny permissions on the Files section for it.

    Also, I would recommend you investigate the following forum thread that provides a workaround for restricting the access to a specific folder in the file system.

    Please give us more detailed information if there is some misunderstanding.

    Sincerely yours,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Allen
    Allen avatar
    71 posts
    Registered:
    04 Aug 2007
    15 Jan 2008
    Link to this post
    I apologize that I wasn't completely clear.

    I think the forum post to which you refer might be part of the answer, but the challenge I have is that I don't even want the SiteFinity application to "see" the wss folder at all.  Unfortunately, in testing, if SiteFinity does not have permission to even read the folder, when a user clicks the Files menu option, the application throws an uncaptured .NET error ("Permission Denied").  So, instead of SiteFinity listing the folder or its contents in the Files tree view, I would instead like it to skip it alltogether.  I was hoping that there would be some way in the web config to have the application ignore this folder.  Hopefully, this is clearer.

    Thanks for you help.

  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    16 Jan 2008
    Link to this post
    Hello Allen,

    Unfortunately, is it not possible to remove the folder from the File Manager when it actually exists in the project File system. We are sorry for the inconvenience caused.

    If you prefer, you can set the Manage Files permission (see my first reply) for a particular user role to false and this would hide the Files section/tab for that role altogether.

    Kind regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered