+1-888-365-2779
Try Now
More in this section

Flash Issue

6 posts, 1 answered
  1. Bo Sep
    Bo Sep avatar
    21 posts
    Registered:
    27 May 2010
    10 Feb 2011
    Link to this post
    Hi there,
    I have this flash file to embed in Sitefinity.

    <script type="text/javascript">
        document.write('<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width="750" height="550" id="index" align="middle">');
        document.write('<param name="movie" value"Http://.../resources/training/overview/index.swf" />');
        document.write('<param name="quality" value="high" />');
        document.write('<param name="bgcolor" value="#ffffff" />');
        document.write('<embed src="http://.../resources/training/overview/index.swf" quality="high" bgcolor="#ffffff" width="750" height="550" name="index" align="middle" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />');
                </script>


    What's the best way to implement this. I created a user control, but it does not work.

    Thank you
    Regards
    Bo
  2. Keith
    Keith avatar
    67 posts
    Registered:
    13 Sep 2010
    10 Feb 2011
    Link to this post
    What did you put in your user control?

    I made a user control for specifically this reason, and it works fine.
    My code:

    <%@ Control Language="VB" AutoEventWireup="false" CodeFile="HomeFlash.ascx.vb" Inherits="UserControls_MasterPageControls_HomeFlash" %>
     
    <div style="padding-bottom:1px;">
    <object id="flash1" data="/Files/Flash/complete_loader.swf" height="200" style="width: 861px" type="application/x-shockwave-flash" wmode="opaque">
      <param name="movie" value="/Files/Flash/complete_loader.swf" />
    </object>
     
    </div>

    Alternately, there is supposedly a way to do this via a Generic Content control, but we could never get it to work properly, so we did this.
  3. Bo Sep
    Bo Sep avatar
    21 posts
    Registered:
    27 May 2010
    10 Feb 2011
    Link to this post
    daaaa......

    I forgot to change the name in toolboxcontrols...

    Thank you for responding Keith.

    Have a great day...

  4. Bo Sep
    Bo Sep avatar
    21 posts
    Registered:
    27 May 2010
    10 Feb 2011
    Link to this post
    Hey Keith,
    It works fine now , except dropdown menu on the same page in IE ceases to function, but they seem to work fine in all other browsers..Any ideas?

  5. Keith
    Keith avatar
    67 posts
    Registered:
    13 Sep 2010
    10 Feb 2011
    Link to this post
    What exactly is it doing? If it is being occluded by the flash object, add wmode="opaque" property to your <object> tag (see my code).  We had the same problem and that fixed it.
    Answered
  6. Bo Sep
    Bo Sep avatar
    21 posts
    Registered:
    27 May 2010
    10 Feb 2011
    Link to this post
    It worked...
    Thanks a lot Keith.
Register for webinar
6 posts, 1 answered