1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Flash question

Flash question

19 posts, 0 answered
  1. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    26 Jan 2010
    Link to this post
    How do you get a flash movie on a page like this link

    http://www.sitefinity.com/support/video-tutorials/extending-sitefinity/adding-simple-functionality-with-user-controls.aspx

    It has a single movie and has the Play, pause, Etc, controls at the bottom. 

    I have tried everyway I can think of and I can get a video to show up and play but no controls.  I have tried creating a custom user control and have tried embedding the html/javascript geenerated by Flash CS4.

    A step by step tutorial would be appreciated.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    19 May 2017
    27 Jan 2010
    Link to this post
    Hi bleutiger,

    The player you refer is The Viddler video player, that we use for streaming. You can gather more information at The Viddler video player - Documentation. Another option is using YouTube player - Add a YouTube player to your website.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    Does anyone know how to do this with the FLV Player that you publish out of Flash directly?

    I realize that it publishes an HTML doc with javascript embedded but how can we pout that javascript on a sitefinity page?

    The issue here is that the flash video that I need to display cannot be hosted anywhere else like You Tube.

  4. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    Also  I am a little confused on the viddler thing.  Is it something we have to upload our videos to?
  5. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    Ok  having read mkre on Viddler I think I understand now.  Are you guys using the first release or the latest beta release.  Yours seems pretty stable so I was curious.
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    27 Jan 2010
    Link to this post
    Hello bleutiger,

    Could you clarify on which release are you talking about? You can take a look at this forum thread containing a sample control for adding flash video: Add SWF o0r Flash video in the pages.. Note that the path to the flash video has to be absolute (full).

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    Ok let me start over.

    I have a flash video that cannot be uploaded to a public site such as youtube or viddler.  I can get the flash movie to play using the built in flash icon in the generic content module or using a user control like the one you have listed in this forum discussion.

    What I cannot figure out is how to get the play, pause, fullscreen, volume buttons that I created using a skin in Flash CS4 to appear on the page.  (The FLVPlayer Component in Flash CS4)

    When you publish your movie in Flash it will make an html file that has javascript built into it, an swf file for your movie, and an swf file for the skin.

    When you test the movie in Flash everything works great but I cannot figure out how to get the skin and controls to work in sitefinity.  The movie shows up but not the buttons.

    Hopefully that clarifies things and you have a better understanding of what I am trying to accomplish.  If not I can give more info.

  8. Haddicus
    Haddicus avatar
    17 posts
    Registered:
    19 Dec 2009
    27 Jan 2010
    Link to this post
    There is a file that flash will publish to the directory you publish to that contains the navigational controls you are speaking of. Make sure that you upload that file to your server in the same directory that you are playing the flash file from, and you should be good to go. Without that file on the directory, flash will not load the controls.
  9. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    I agree.  I have that file in the same location as well.

    the two files are

    FlashPlayerTest.swf  This is the movie file
    SkinUnderPlayStopSeekFullVol.swf

    They are both in my Files directory in sitefinity but the controls do not appear.
  10. Haddicus
    Haddicus avatar
    17 posts
    Registered:
    19 Dec 2009
    27 Jan 2010
    Link to this post
    What is the directory of where you want the file to run?
  11. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    I'm not trying to be dense here but I am not sure I understand the question.

    Both of the swf files reside in  the "Files" directory off of the root.  But the page that is calling the files is root/programs/myfideo.aspx

    or something to that effect.


  12. Haddicus
    Haddicus avatar
    17 posts
    Registered:
    19 Dec 2009
    27 Jan 2010
    Link to this post
    Try to create a physical directory for that folder(e.g.: add a folder named "programs" to your site root).... and try and drop the interface swl file into a folder that mimics the dynamic url created within the framework. That might temporarily fix it. I think there also is a way to set the load url for that interface file, within as3, that might be the best bet with the MCV model. The example before is a temporary work around till that is figured out ultimately. This is ultimately a flash question, so you might discuss on the adobe forums how to set a specific path for the interface file, verses the running directory, as MVC directories are virtually created through the controller.
  13. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    Thanks for the help Sean I will check on the adobe forums.  I can't be the only person who wants to do this.

    I will post what I find here.

    In the meantime if anyone else has any answers please jump in.
  14. Haddicus
    Haddicus avatar
    17 posts
    Registered:
    19 Dec 2009
    27 Jan 2010
    Link to this post
    No problem. I just began working with sitefinity, but I imagine I'll be using that player at some point so knowledge of how to link to a specific file verses same directory would defiantly help. I don't have flash installed on this PC or I would have tried a few ideas I have. I may try a few things tonight and see if I can get it working. If I figure anything out I'll let you know.
  15. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    27 Jan 2010
    Link to this post
    Hey Sean,

    I tried hard coding the URL directly in the actionscript for the skin but no go.

    The weird thig is that it reserves enough space for the controls to fit below but the just don't show up.

    Very frustrating.
  16. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    28 Jan 2010
    Link to this post
    does anyone else have  a solution for this?

    Anyone else from Telerik want to chime in.

    I can't believe it is this hard to do.  I cannot be the only one who want to do this.
  17. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    28 Jan 2010
    Link to this post
    OK found something interesting.

    It seems that this is a browser problem.  My player shows up in FireFox but not in IE8.

    So not A sitefinity issue I guess. 

    Thanks to all for the help.
  18. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    28 Jan 2010
    Link to this post
    One more thing for anyone else who has this issue.

    I seems this problem is sepecific to my development machine at work.  I remoted to my home computer and everything works just fine.

    Found some forum posts that say to make sure you have the latest version of Adobe Player.  Hope this helps someone in the future.
  19. Haddicus
    Haddicus avatar
    17 posts
    Registered:
    19 Dec 2009
    28 Jan 2010
    Link to this post
    That makes sense about the player version. Since each browser handles their own plug-in versions and installs.
Register for webinar
19 posts, 0 answered