+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Image Links Broken after Upgrade from 3.5 to 3.7SP4(Updated With New Info)

Image Links Broken after Upgrade from 3.5 to 3.7SP4(Updated With New Info)

3 posts, 0 answered
  1. Myron
    Myron avatar
    22 posts
    Registered:
    02 Jul 2012
    22 Jul 2011
    Link to this post
    Background:
    Moving project from SiteFinity 3.5 to SiteFinity 3.7SP4
    SiteFinity 3.7 SP4 Blank Project

    Here is the image link before the move to sitefinity 3.7SP4
    http://localhost/Libraries/XXXXX_Images/subpage_theme.sflb.ashx
    Here is the image link after the move
    http://localhost/App_Master/%5BLibraries%5D81bec1c3-1f35-4c69-959a-2a2465693388

    Where would I find how these links are generated?

    Thanks

    Edit:  Here is some more information.  I am using a custom template that was used in Sitefinity 3.5 and its just using a content place holder control.
  2. Myron
    Myron avatar
    22 posts
    Registered:
    02 Jul 2012
    22 Jul 2011
    Link to this post
    I have solved it temporarily by using a generic content instead of image.  However, if someone could please tell me what went wrong, it would be greatly appreciated.
  3. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    28 Jul 2011
    Link to this post
    Hi Myron,

    Can you please try the approach in this article: http://www.sitefinity.com/devnet/kb/sitefinity-3-x/how-to-replace-urlwhitespacechar-in-your-images-and-documents-library-items-after-upgrade-from-3-2-to-3-5.aspx. Also please check your handler mappings in IIS. Make sure that you have the handler mappings for .sflb.ashx extension.

    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
3 posts, 0 answered