Try Now
More in this section

Forums / Developing with Sitefinity / Issue with localization

Issue with localization

3 posts, 0 answered
  1. Muhammad Saqib
    Muhammad Saqib avatar
    95 posts
    09 Sep 2009
    19 Oct 2010
    Link to this post

    I have my web site in english, now i want to add chinese version for some pages only. what i want to do is

    1. Don't let the language change automatically even if the language preference in browser is set to other language. I mean if site support english and chinese and user preference in browser is set to chinese, but when visitor comes to site the english version must be displayed unless he changes himself.

    2. How to add a drop down or something on the site to allow use to change language, so that if user changes the language he'll see that language's pages unless he changes back to other language.

    3. If a translation of any page/menu item etc (any text) doesn't exits, the default language page should be displayed.

    Looking to hear from you soon.
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    01 Feb 2016
    20 Oct 2010
    Link to this post
    Hi Muhammad Saqib,

    Thank you for using our services.

    1) For the first requirement you have to set the localization not to automatically set the language:
    <localization autoSetClientLanguage="false"...>

    2) In the Navigation section in the page toolbox you have a language selector control which you can add to your template.

    3) This cannot be achieved using out of the box functionality. What you have to do is to use the Pages API and get all pages. Attached is a sample control which does that.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Muhammad Saqib
    Muhammad Saqib avatar
    95 posts
    09 Sep 2009
    25 Oct 2010
    Link to this post

    so far its working fine for me
Register for webinar
3 posts, 0 answered