1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / limiting content seen on newsview

limiting content seen on newsview

4 posts, 0 answered
  1. Dave
    Dave avatar
    14 posts
    Registered:
    04 Feb 2009
    26 Feb 2009
    Link to this post
    I have a news view on my homepage and would like each news item to display just a few sentences of the content for each newsitem.  Currently I have the ID on my literal tag  "Content" but as it is supposed to it is showing all the content.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    26 Feb 2009
    Link to this post
    Hello Dave,

    You could add the control below to the NewsView designer ~/Sitefinity/Admin/ControlTemplates/News/Design/NewsViewControlDesigner.ascx

    <sfDesignSettings:ContentSetting id="ContentSetting1" TargetID="content"></sfDesignSettings:ContentSetting>  

    When the TargetID is set to content - it will edit your content. If it is summary, you can display certain words of you summary. You can put the control between <MasterSettings></MasterSettings> nodes

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Dave
    Dave avatar
    14 posts
    Registered:
    04 Feb 2009
    26 Feb 2009
    Link to this post
    Thank you for the response.  This does create a control in the settings on the newslist, however when I enter a number for the amount of words to be displayed it doesn't effect anything.  Then when I go back to the settings, the number I had entered is no longer there.  Also, will this same control work for the Title of the news event.  Turns out the summary is not required, so we are going to display the title.  I really appreciate your help.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    26 Feb 2009
    Link to this post
    Hi Dave,

    Could you try removing the control and then adding it again on the page. Probably something has been cached. It is working at my end.

    Let me know the result.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
4 posts, 0 answered