1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Multiple forms on a page

Multiple forms on a page

7 posts, 0 answered
  1. Steve Mustafa
    Steve Mustafa avatar
    9 posts
    Registered:
    13 May 2010
    13 Jul 2010
    Link to this post
    I have this interesting issue.

    I have a web page with multiple forms, because one of the forms is a javascript form (jQuery).  Now here's the nifty part. The powered by sitefinity logo is getting appended to the end of the first form (which runs at the server) but not after the other forms (which are not supposed to run at the server).

    Any ideas on how to solve that?

    This is on the community edition 3.7 by the way.
  2. George
    George  avatar
    204 posts
    Registered:
    05 Sep 2006
    14 Jul 2010
    Link to this post
    Hi Steve,

    Take a look at this thread here

    You can hide the default sitefinity logo and add a custom logo placeholder to the footer of your website.

    use the following code from Kevin Hillinger

    function hideDefaultPoweredByLogo() { 
       
        var DEFAULT_LOGO_CSSCLASS = "poweredBySitefinityLogo"
        var nodeList = document.getElementsByTagName("p"
       
        var defaultPoweredByLogo = null
       
        for (i = 0; i < nodeList.length; i++)  
        
            if (nodeList[i].getAttribute("class") == DEFAULT_LOGO_CSSCLASS || 
                nodeList[i].getAttribute("className") == DEFAULT_LOGO_CSSCLASS) { 
                defaultPoweredByLogo = nodeList[i]; 
                break
            
        
       
        if (defaultPoweredByLogo != null)  
        
            var filler = document.createElement("span"); 
            filler.style.display = "none"
       
            var parent = defaultPoweredByLogo.parentNode; 
            parent.replaceChild(filler, defaultPoweredByLogo); 
        
    }




    Best,

    G
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    14 Jul 2010
    Link to this post
    Hi G-force,

    Just to let you know hiding the default logo of Community Edition violates our policy. Have this in mind when you are trying to make some hacks.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. George
    George  avatar
    204 posts
    Registered:
    05 Sep 2006
    14 Jul 2010
    Link to this post
    Hi Ivan,

    Thank you for your input. I just suggested a solution from another thread ...
  5. Steve Mustafa
    Steve Mustafa avatar
    9 posts
    Registered:
    13 May 2010
    14 Jul 2010
    Link to this post
    Not interested in removing the logo, I just want it pushed down to the end of all of the forms rather than at the end of the form that runs at the server.
  6. George
    George  avatar
    204 posts
    Registered:
    05 Sep 2006
    14 Jul 2010
    Link to this post
    Steve,

    What I suggested is that you hide the default Logo and place the same logo at your desired spot. Since you are using the community edition you have to have the logo on your website. However, sometimes you will have an issue in the layout with the default logo not being placed in the footer. The solution I suggested is your best shot.

    Regards,

    George
  7. Steve Mustafa
    Steve Mustafa avatar
    9 posts
    Registered:
    13 May 2010
    14 Jul 2010
    Link to this post
    G-Force,

    Rock!  I'll give it a whirl ASAP. Hope, it works.

    Cheers!
Register for webinar
7 posts, 0 answered