Try Now
More in this section

Forums / Developing with Sitefinity / News Module not working since mapping to a control

News Module not working since mapping to a control

2 posts, 0 answered
  1. James@Nw
    James@Nw avatar
    265 posts
    05 May 2009
    03 Mar 2011
    Link to this post
    Hi Guys,

    We're having a problems getting to the News Module since we mapped a control. This is the error we get.

    A required control was not found in the template for "~/Sitefinity/MappedTemplates/News/ListPageMaster.ascx". The control must be assignable form type "System.Web.UI.WebControls.HyperLink" and must have ID "createNewButton".

    Could you please let me know what might be causing this? To me, the mapped controls should have no effect on the actual CMS.

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    25 Oct 2016
    03 Mar 2011
    Link to this post
    Hello James@Nw,

    You can mapped ListPageMaster external template and in this template you have removed a control with ID="createNewButton". This control createNewButton is not part of the ListPageMaster, because ListPageMaster  is used for the front end control NewsView. The control with ID="createNewButton" is used for the backend and inside NewsItemsList.ascx

    Ivan Dimitrov
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
2 posts, 0 answered