1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / News providers not working with search indexes

News providers not working with search indexes

7 posts, 0 answered
  1. Darren
    Darren avatar
    72 posts
    Registered:
    19 Mar 2008
    20 Jun 2008
    Link to this post
    Is there an issue with search indexes with multiple news providers?
    I have 19 news providers so in a search index I've added each news provider to ensure the search covers all 19 news providers.
    However, what I actually get in search results is effectively the first news provider searched 19 times rather than results from the 19 different news providers.

    So for instance if theres a news item in my first news provider it'll be returned 19 times in the search results but if I have a news item in any of the other news providers it won't be returned at all showing it's just indexing the first news provider, not the actual news providers selected in the news index.

    I suspect theres something I'm missing here since I haven't found this issue raised in another thread yet.
  2. Nikola
    Nikola avatar
    51 posts
    Registered:
    24 Sep 2012
    20 Jun 2008
    Link to this post
    Hi Darren,

    No similar issue has been reported so far, but we'll try to reproduce your case and let you know about the results.

    Best wishes,
    Nikola
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Darren
    Darren avatar
    72 posts
    Registered:
    19 Mar 2008
    20 Jun 2008
    Link to this post
    I'm not sure if this helps but the actual news page has 19 news article controls, each with its own provider.
    Only one control is visible at any one time depending on who's logged in since different users will be accessing the site from different countries and so will be having different local content.

    Everything works fine except for the search which seems to totally ignore the news provider selected and just use the first 'global' news provider.
    I don't think the fact that all the news articles are viewed through a single page is causing the problem but I'm just trying to identify anything unusual that could be causing an issue.

    Thanks again for looking into this at the same time.
  4. Nikola
    Nikola avatar
    51 posts
    Registered:
    24 Sep 2012
    23 Jun 2008
    Link to this post
    Hi Darren,

    Thanks for the additional info.
    The problem is not caused by the way you have organized the news to show on single page. Most probably the NewsIndex is taking the Default News Provider only.

    We'll let you know about the possible resolution shortly.

    Sincerely yours,
    Nikola
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Sebastian Menendez
    Sebastian Menendez avatar
    19 posts
    Registered:
    15 Oct 2004
    25 Jun 2008
    Link to this post
    Hi,

    I'm having exactly the same problem. Any solutions?

    Thanks,

    Sebastian
  6. Nikola
    Nikola avatar
    51 posts
    Registered:
    24 Sep 2012
    26 Jun 2008
    Link to this post
    Hello Sebastian Menendez,

    Find the attached file which contains a workaround for the NewsIndexProvider.
    Extract the contents of the zip file in your App_Code folder and follow step 2 of the readme.txt file included, to add the nessecary values in the web.config.

    We strongly recommend you first test it with a non-production version of Sitefinity on a test server or in a test environment.

    Let us know if it worked for you.

    Regards,
    Nikola
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Sebastian Menendez
    Sebastian Menendez avatar
    19 posts
    Registered:
    15 Oct 2004
    26 Jun 2008
    Link to this post
    Nikola,

    Thanks for the prompt reply. I've tested it and it's working fine.

    []'s

    Sebastian
Register for webinar
7 posts, 0 answered