1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Newsletter Module Error When Opening

Newsletter Module Error When Opening

7 posts, 0 answered
  1. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    06 Nov 2008
    Link to this post
    Hi -

    I am trying to use the Newsletter Module. I can run it on my local machine but when I try on a site we are developing that is on another machine, I get this error.
     

    Server Error in '/' Application.

    A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    I read up on a few thread on errors here  - the one thing i tried is to take my local assembly 3889AC4AF542BAC3C62ABB154E78FEA8.dll  and copy it into the \Sitefinity\ServiceAssemblies folder. Then I received this error.

    This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.


    Any ideas?

    Thank you.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    10 Nov 2008
    Link to this post
    Hello Laura,

    Could you send us the Sitefinity.log file located in the project App_Data directory?

    Sincerely yours,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    10 Nov 2008
    Link to this post

    Is this what you are looking for?  I have two sites and one of them does not have a log file.  I copied one in there, and made sure it says 

    <healthMonitoring enabled="true" heartbeatInterval="0">

     in the webconfg, but it is still not writing to the sitefinity.log.

    Thank you.


    Exception Type: Telerik.WebServices.DynamicProxy.ProxyInstantiationException

    Message: An error occured while instantiating the proxy type.

    Source: Telerik.DynamicWebServices

    Stack Trace:
       at Telerik.WebServices.DynamicProxy.WebServiceDynamicProxy.CreateInstance(String objTypeName)
       at Telerik.WebServices.DynamicProxy.WebServiceDynamicProxy.BuildProxy()
       at Telerik.WebServices.DynamicProxy.WebServiceDynamicProxy..ctor(String wsdlLocation, Cookie authCookie)
       at Telerik.Notifications.Services.MailingServiceProxy..ctor(String wsdlUri)
       at Telerik.Notifications.Newsletters.WebControl.Admin.ControlPanel.CreateChildControls()
       at System.Web.UI.Control.EnsureChildControls()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    ------------------------------------------------------------------------------------
    - L1 -------------------------------------------------------------------------------

    Exception Type: System.Reflection.ReflectionTypeLoadException

    Message: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

    Source: mscorlib

    Stack Trace:
       at System.Reflection.Module._GetTypesInternal(StackCrawlMark& stackMark)
       at System.Reflection.Assembly.GetTypes()
       at Telerik.WebServices.DynamicProxy.WebServiceDynamicProxy.CreateInstance(String objTypeName)
    ------------------------------------------------------------------------------------

  4. Dave
    Dave avatar
    5 posts
    Registered:
    14 May 2008
    13 Nov 2008
    Link to this post
    I have same error...
    In other Forums I found a potential solution, but it did not work for me.  The is that initially the Newsletter did work - when logged in via Sitefinity Projects interface - when the Projects are in the c:\program files\telerik.....folder.
    When you copy the site to the live server, an automatically created .dll file should be NOT copied (/sitefinity/serviceassemblies/3889AC4AF542BAC3C62ABB154E78FEA8.dll).
    When you run the site for the first time on the live server, this file is supposed to get created.
    On my live site, this file DOES NOT get created.  It may be a rights issue, but I have NOT been able to fix it even in making the rights to the directory on the server and the virtual directory in IIS modified to allow writes / changes.
    As a result, without that file, when loggin in you sometimes get a timeout issue and have to refresh to get the sitefinity admin module to show up; and the newsletter module never comes up - it just times out.
    If I copy the file from the program files version, the timeout issue goes away but the Newsletters do not MAIL.  You can then get in and modify them, do everything else, but the SMTP does not work.  You get an error that says it MOVED.

    HELP please, this is a biggie for my client.
    DAVE
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    13 Nov 2008
    Link to this post
    Hi Dave,

    Does this happens even if you use the same project version? There shouldn't be problem if you upload the service assembly build with the same project.
    We are aware of these issues anyway and are thinking for the best approach in solving them. We still cannot commit to any time frame for it, but it should be soon.

    Best wishes,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. John
    John avatar
    21 posts
    Registered:
    25 Nov 2008
    09 Mar 2009
    Link to this post
    Hi,

    I was wondering if there has been any progress made here?  I recently installed the 3.6 hotfix, and I was getting an error before deleting the .dll in the ServiceAssemblies directory.  Just seeing if there has been any kind of update or change here.

    Thanks,
    John
  7. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    10 Mar 2009
    Link to this post
    Hi John,

    Yes, there is progress with this issue. Although the assembly should be deleted after an upgrade, Sitefinity properly resolves the web service after web site deployment or changing of the hosts.

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
7 posts, 0 answered