1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Problem to add .doc File from Library to Generic Content

Problem to add .doc File from Library to Generic Content

4 posts, 0 answered
  1. Adalbert
    Adalbert avatar
    8 posts
    Registered:
    23 Jan 2009
    03 May 2009
    Link to this post
    Hello
    I am new in Sitefinity and have a large problem.
    I added some WORD file to the Document Library and want to add it afterwards to the Generic Content control to the page.
    I can open the select box but the select button on the left side is not active. I just can click "Cancel".
    It would be great if somebody can tell me what I am doing wrong.
    Thanks for your help
    Adalbert
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    03 May 2009
    Link to this post
    Hello Adalbert,

    To add a document to Generic Content Control on a page you should do the following.

    1. Upload several document in one of your libraries.
    2. Create a page and drop Generic Content control on this page.
    3. Open the control and from the toolbar and select "Insert a ducument"
    4. There are two options - to upload the file or select form already uploaded files.
    5. Onece you click "select from already uploaded files" you should see your document libraries form where you can select whic document you want to upload.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Adalbert
    Adalbert avatar
    8 posts
    Registered:
    23 Jan 2009
    03 May 2009
    Link to this post
    Hello Ivan,
    thanks for your fast respose,
    I have done it exactly in this way and I see my document there.
    But the "select" link left of my document is not active! I can not select my document. Just the "Cancel" on the botton is active.

    What can I do?

    Thanks a lot for your help.
    Adalbert
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    05 May 2009
    Link to this post
    Hello Adalbert,

    I am not able to reproduce the problem you have. Check out attached video. If the problem persists could you tell us which version you use and whether you have made any customization that could affect the designer.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
4 posts, 0 answered