+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Problem with Custom CategoriesView

Problem with Custom CategoriesView

3 posts, 0 answered
  1. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    07 Oct 2010
    Link to this post

    Greetings!

    I have a problem in Sitefinity 3.7 SP4 with custom CategoriesView which was described in article(http://www.sitefinity.com/blogs/ivandimitrov/ivanposts/10-02-15/optimize_backend_categoriesview_performance_in_sitefinity_3_7.aspx). When I am trying to activate this custom template on Sitefinity 3.7 SP4 It makes strange issue: I can't see link "Categories" to view categories for my module.

    Why can It happen? Maybe you change naming for Telerik.Libraries.WebControls.Admin.LibrariesControlPanel?

    Why this fix didn't include in SP4? I asked this question from SP2 release. =)

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    07 Oct 2010
    Link to this post
    Hi Paul,

    Set the title of the view inside ControlsConfig file as shown below

    <viewSettings hostType="Telerik.Libraries.WebControls.Admin.LibrariesControlPanel">
      <views>
        <remove name="CategoriesView" />
        <add name="CategoriesView" viewType="CategoriesViewCustom, App_Code" title="CategoriesView"></add>
      </views>
    </viewSettings>


    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    07 Oct 2010
    Link to this post

    Hi Ivan!

    Thanks for reply! Now It works as it should.

Register for webinar
3 posts, 0 answered