+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Problem with files provider

Problem with files provider

5 posts, 0 answered
  1. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    27 Sep 2010
    Link to this post

    Hello!

    I have a problem with Files provider. I enabled it as it said in article: http://www.sitefinity.com/devnet/kb/sitefinity-3-x/how-to-enable-the-files-provider-for-images-and-documents-module-in-sitefinity-3-7-sp3.aspx . And as I check it after all works fine. But today I found that all my images that was stored in database now doesn' show. Why can it happen? 

    I found that images doesn't shows after I installed IIS URL Scan Module (http://weblogs.asp.net/scottgu/archive/2010/09/24/update-on-asp-net-vulnerability.aspx). Maybe this tool make some changes?

    Thank you.

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    27 Sep 2010
    Link to this post
    Hi Paul,

    Once you switch the provider to Files, all items that you will upload,  will go to the file system. The content and metadata of the files that you currently have will remain stored in the database and served by Nolics provider.The difference concerns only the newly uploaded files and where they will be stored.

    What changes have been made between setting the provider and the time this issue occurred? You said that everything was working fine until today.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    28 Sep 2010
    Link to this post

    Hi Ivan!

    Yes, as I said I have changed provider and all was fine. But about a week ago I read about ASP.NET Vulnerability and checked my site. I made changes in web.config and create Error.aspx. Yesterday I read about URLScan (http://weblogs.asp.net/scottgu/archive/2010/09/24/update-on-asp-net-vulnerability.aspx) and made changes for my site. After that I found that all my images that uploaded to database doesn't work. I tried to extract my images from database by your method (http://www.sitefinity.com/blogs/ivandimitrov/ivanposts/10-01-31/save_images_from_the_images_and_documents_module_back_to_the_file_system.aspx) and It was extracted perfectly. Also I want to say that in admin interface of Images and Documents images doesn't show too. 

    What can cause this? Maybe you can suggest me something?

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Sep 2010
    Link to this post
    Hi Paul,

    I have not see this issue before. Check whether you have not changed the provider name which could cause this issue. Another option is to migrate all images from the database to the files provider as shown here -Switching from database to filesysystem for files. , since all images are still in the database.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    28 Sep 2010
    Link to this post

    Hi Ivan!

    Thank you for the links. I fixed problem with images. I tried to explore image urls and found that something wrong in description of provider: ~/{Provider}/{LibraryName}/{GUID}.sflb.ashx. I replace this by  "~/{Provider}/{GUID}.sflb.ashx" and all became normal. There is only one question for me: when did I change urlRewriteFormat =)

Register for webinar
5 posts, 0 answered