1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Problems with ButtonSelector

Problems with ButtonSelector

2 posts, 0 answered
  1. John
    John avatar
    14 posts
    Registered:
    07 Nov 2008
    30 Sep 2009
    Link to this post
    Hi,

    I tried implementing the ButtonSelector control as suggested in this thread, but am sitll having an issue:

    The Selector dialog says "You have no libraries created or no items uploaded in them" when it's invoked. But I do have some image libraries with images in them. Browsing the file system works fine.

    The version of Sitefinity I'm running is 3.7 SP1.
    The version of Telerik.Libraries.dll that I'm referencing in the page, which contains the ButtonSelector class is 3.7.2022.2.

    Can anyone help me?

    Thanks!
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    30 Sep 2009
    Link to this post
    Hello John,

    Try changing the ButtonSelector WindowNavigateUrl as below:

    WindowNavigateUrl="~/Sitefinity/UserControls/Dialogs/ImageEditorDialog.aspx" 

    If you want to use the selector for documents navigate to ImageEditorDialog and set its DisplayMode property to "Documents". I hope this helps.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
2 posts, 0 answered