1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Problems with RadTreeView in Custom Module

Problems with RadTreeView in Custom Module

3 posts, 0 answered
  1. Adam
    Adam avatar
    63 posts
    Registered:
    30 Jan 2008
    17 Sep 2008
    Link to this post
    I'm working with a RadTreeView in a custom module and it only mostly works.  The TreeView is showing up flat rather than showing the heirarchical view.  I think it has something to do with the javascripts not properly initializing.  I set 

    EnableEmbeddedScripts= true,

    but that didn't change anything.  The data still showed as flat.  Any suggestions?

  2. Adam
    Adam avatar
    63 posts
    Registered:
    30 Jan 2008
    17 Sep 2008
    Link to this post
    More info:  The Context Menus work fine, so I know it's loading the javascript.  It just won't show the data in a heirarchical view.  The nodes are flat.

    I'm using the newest RadTreeView.  Here's my Web.Config:

     
    <dependentAssembly> 
         <assemblyIdentity name="RadTreeView.Net2" publicKeyToken="d14f3dcc8e3e8763" culture="neutral"/>  
         <bindingRedirect oldVersion="6.3.5.0" newVersion="6.3.6.0"/>  
    </dependentAssembly> 
  3. Adam
    Adam avatar
    63 posts
    Registered:
    30 Jan 2008
    18 Sep 2008
    Link to this post
    Solved!  But not in the way I was expecting.  Turns out my RadTreeView control is not the latest version as I had thought.  It's loading the version that comes with Sitefinity which does not support showing hierarchical data from an ObjectDataSource (http://www.telerik.com/help/aspnet/treeview/tree_databinding_overview.html). 

    So since I was loading the Data using LINQ, I ended up finding this code to convert the LINQ results to a DataTable:
    http://weblogs.asp.net/stevesloka/archive/2008/01/28/linq-to-datatable.aspx?CommentPosted=true#commentmessage

    Which works exactly as advertised.
Register for webinar
3 posts, 0 answered