1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / UserControls Dialog problem in IE8

UserControls Dialog problem in IE8

3 posts, 0 answered
  1. Nadya
    Nadya avatar
    52 posts
    Registered:
    17 Dec 2008
    08 May 2009
    Link to this post
    Hi ,

    I am developing a Sitefinity website using Sitefinity 3.6 and I am experiencing a problem with UserControls' Dialogs - Links and Image Dialog when opening then Html Editor.

    I have my own HtmlEditor which is inheriting from RadEditor and IWebUITypeEditor. To enable Image, Dialog and Links Managers I am doing:

    protected override void CreateChildControls() 
            base.CreateChildControls(); 
            this.Controls.Add(this.Page.LoadControl("~/Templates/EditorScripts.ascx")); 
     where EditorScripts.ascx is file with javascripts for opening all managers, which I saw in the forum.

    So everything works fine in FF , IE7 but in IE8 the following thing is happening:

    1.  Open Html Selector
    2.  Insert link/ Image or just open the Links/Image Dialog and hit Cancel
    3.  Try to insert another link or image - the "Insert" and "Cancel" buttons      are not there anymore so the dialog cannot be closed normally.

    I tried to look up the problem but all I found was that there're sometimes issues with rad controls in IE8 and I found an advice to use the IE8 Compatibility Meta Tag, which I googled as 

    <meta http-equiv="X-UA-Compatible" content="IE=8" /> 

    Well, did not helped.

    So I upgraded to Sitefinity 3.6 SP1 Hotfix - the same issue is keep occuring with and without the mata tag.

    I would really appreciate any help on this.

    Thank You,
    Best Regards Nadya
  2. Nadya
    Nadya avatar
    52 posts
    Registered:
    17 Dec 2008
    09 May 2009
    Link to this post
    Hi again,

    I want to add a couple of things I found out.

    I tried to reproduce the bug in Sitefinity's Generic Content. The buttons are not disappearing but after the first insert/cancel they are jumping a little bit down.
    So I reproduced it again in my Html Editor and maximize its window - the buttons were there.
    Actually it is not that buttons are jumping but the radwindow of the image/link dialog is getting bigger.
    In java scripts I am using :

     editor.showExternalDialog( 
       '<%= Page.ResolveUrl("~/Sitefinity/UserControls/Dialogs/LinksDialog.aspx") %>'
       editorArgs,  
       750,  
       600,  
       myCallbackFunction,  
       null,  
       'ImageLibraryDialog',  
       false,  
       Telerik.Web.UI.WindowBehaviors.Close + Telerik.Web.UI.WindowBehaviors.Move,  
       false,  
       true
    }; 

    So I changed the window size from (750, 600) to (750, 460) and now the indow is fine and everything's there.

    On generic content I am still getting the resized window and again only in IE8.

    So basically I fixed my problem,  if letting you know about this resizing of user dialogs is helpful I'd be glad.

     Regards,
     Nadya

  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    12 May 2009
    Link to this post
    Hi Nadezhda ,

    Thank you for letting us know about this issue.
    We will test it carefully and include the css/template fix as soon as possible.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
3 posts, 0 answered