1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Visual Studio 2010

Visual Studio 2010

7 posts, 0 answered
  1. TIOS
    TIOS avatar
    48 posts
    Registered:
    22 Mar 2006
    14 Apr 2010
    Link to this post
    Hi,

    From read the telerik forums looks like the new ajax SP will be out later this week with full support for VS2010.  Will we getting full support in Sitefinity for VS2010?  Im quite keen to switch it all over! (After testing ofcourse!!)

    Thanks,
    Chris
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    14 Apr 2010
    Link to this post
    Hello Chris Bond,

    Sitefinity runs properly under VS 2010. We have not performed all tests yet and this is why we could not officially announce that we provide full support for it. Most probably this will happen for the next SP of Sitefinity. Also, Sitefinity can work only with VS 2010 and .NET 3.5 and 2.0.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. TIOS
    TIOS avatar
    48 posts
    Registered:
    22 Mar 2006
    14 Apr 2010
    Link to this post
    Ok thanks - think i'll wait for SP just to be safe will do some testing though thanks for the fast response!
  4. TIOS
    TIOS avatar
    48 posts
    Registered:
    22 Mar 2006
    05 May 2010
    Link to this post
    Any news when we might expect the SP, would love to move our sitefinity site to VS2010 (dont want to do it before the SP though due to the amount of traffic the site has).

    What options do you need to choose when running the upgrade wizard as i'm tempted to have a play with it to check though?
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    05 May 2010
    Link to this post
    Hi Chris Bond,

    We are considering adding support for 4.0 for 3.7 version. The next SP is scheduled after the middle of July, because we are waiting for Q2 release of the RadControls for ASP.NET AJAX.
    When you run a project in VS2010 you do not have to upgrade the project to .NET Framework 4.0 which is currently not supported.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. TIOS
    TIOS avatar
    48 posts
    Registered:
    22 Mar 2006
    05 May 2010
    Link to this post
    Ok great thanks exactly what I needed.  4.0 Support would be great on 3.7 as id rather have it before SF4.0 then you know you're not dealing with related to that just upgrade later on (just my two bucks =)).
  7. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    07 May 2010
    Link to this post
    My trusty dev PC went legs-up a few weeks ago, and so I took the opportunity to go Win-7 and VS-2010.

    I am using VS-2010 to work on my Sitefinity projects now, and so far have not found anything to cause me concern.

    Dot.NET 4.0 support for Sitefinity v3.7 would be nice, but so far I've had no issues using VS-2010 and the Dot.NET 3.5 based projects... and the 2010 IDE/Editor is simply nicer to use (although the Help sucks).

    Of course, YMMV on that one.

Register for webinar
7 posts, 0 answered