+1-888-365-2779
Try Now
More in this section

Forums / Ecommerce / Ecommerce problems

Ecommerce problems

3 posts, 0 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    02 Sep 2013
    Link to this post
    Hi support,

    At this moment I have some REAL issues with the Ecommerce widgets which prevents me from launching my site.

    1. I can't use the TemplatePath property on the Checkout View steps, so I can only create different templates inside the Sitefinity backend, which is not working for me.
    2. The checkout widget doesn't save the the value of a custom Confirmation page. I don't want to use the builtin template, because I need to implement not-supported payment methods.

    These are issues with my upgrade site from 5.4 to 6.1 but also on a FRESH created website 6.1).
    Can you please confirm that these are bugs or at least help me find out why it isn't working.

    Thank you,
    Daniel

  2. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    02 Sep 2013 in reply to Daniel Plomp
    Link to this post
    Okay, the second issue is something I could resolve.

    When you click on the Redirect to confirmation page option button it will expand the option to actually choose a redirect page. If you are being alert, you will see that as soon this button becomes visible, the selection of the Confirmation section jumps back to its original value, which is, Use template for confirmation step.

    So after you choose a page, you have to again select the second option and be sure that it is actually selected by clicking on the radiobutton itself.

    Seems like a JS bug to me.

    Thanks,
    Daniel
  3. Nayden Gochev
    Nayden Gochev avatar
    32 posts
    Registered:
    03 Nov 2014
    03 Sep 2013
    Link to this post
    Hello Daniel,

    I am glad you were able to find the problem yourself.

    There is a bug in the radio buttons control. If you don't click on the "radio" itself but click on the label this doesn't changes the ratio selected value and the selection of custom confirmation page is lost.
    It is a known issue with the radio buttons and happens only under Firefox. Under both Chrome and IE10, the problem could not be reproduced.

    Please excuse me for the inconvenience caused.

    Regards,
    Nayden Gochev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
3 posts, 0 answered