+1-888-365-2779
Try Now
More in this section

Forums / Ecommerce / Missing Tax Settings backend page in Ecommerce module

Missing Tax Settings backend page in Ecommerce module

4 posts, 1 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    29 Aug 2013
    Link to this post
    After upgrading from 6.0 to 6.1SP1 I do not have the Tax page in my Store Settings section anymore.
    The option is there, but clicking on it navigates to a non-existing page (404 error).

    I actually see that the page doesn't exist in the backend pages.

    Can someone give me the code to reinstall the pages? Also, some labels are not the same as with a fresh install of 6.1.

    Somewhere the upgrade must have missed something?

    Thanks,
    Daniel
  2. Nayden Gochev
    Nayden Gochev avatar
    32 posts
    Registered:
    03 Nov 2014
    02 Sep 2013
    Link to this post
    Hello Daniel,

    it is strange since there was no changes in the settings between 6.0 and 6.1.. the only change was between 5.4 and 6.0. Can you confirm it was working in 6.0 and not in 5.4 I strongly believe that it is possible the upgrade patch from 5.4 to 6.0 to have not been executed which may cause this issue. But from 6.0 to 6.1.x there was no upgrades related to that.

    Can you please also try to open /Sitefinity/ecommerce/TaxSettings and let me know is it working ? just to make sure that just the link is broken not the page itself .


    Regards,
    Nayden Gochev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    02 Sep 2013 in reply to Nayden Gochev
    Link to this post
    Hi Nayden,

    Thanks for the follow up.
    The page TaxSettings was not there, so the url didn't work of couse.

    I first tried to see if I could create my own 'InstallMenus' method using JustDecompile, but I remembered triggering the install / upgrade methods by deleting the version number of the Ecommerce Module inside the SystemConfig.config.

    After I did this, the menu was installed succesfully. I ended up with a duplicate TaxSettings menu item, but deleted the one that didn't worked.

    So, all good now.

    Thanks,
    Daniel
    Answered
  4. Nayden Gochev
    Nayden Gochev avatar
    32 posts
    Registered:
    03 Nov 2014
    02 Sep 2013
    Link to this post
    Hi Daniel,

    Impressive!
    I am glad you manage to fix the issue :) I still wonder why the upgrade script was not executed the first time during the initial upgrade but I only hope only the menus were not upgraded :)

    Regards,
    Nayden Gochev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 1 answered