1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / 4.2 Upgrade Results in Infinite Loop on many pages

4.2 Upgrade Results in Infinite Loop on many pages

18 posts, 0 answered
  1. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    19 Aug 2011
    Link to this post

    This webpage has a redirect loop

    The webpage at http://sourcelink/resources has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    ----------------------------------------------------------------------
    I've just upgraded on of my projects to 4.2. This project has been upgraded to every major release (4.0, 4.1, 4.1 SP1, 4.1 SP2, 4.1 SP3 and now 4.2). I have not had this problem until the latest upgrade. The infinite loop is happening on many pages throughout this site. I cannot find any reason why it's happening on some pages and not others.

    I do not have any dashes or dots in my project name or database. Help!!
  2. Daryl Griffiths
    Daryl Griffiths avatar
    13 posts
    Registered:
    13 Jul 2012
    19 Aug 2011
    Link to this post
    Hi

    I had this issue when the page was set to have multiple urls but didn't have multiple urls entered ... which was my mistake but resulted in the issue you are having... might not be the same but worth a try...

    Regards

    Daryl
  3. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    19 Aug 2011
    Link to this post
    Thanks Daryl. I checked and I did have multiple URLs turned on, but I did have multiple URLs entered. Once I turned off the feature, the page worked again.

    Telerik, is this feature broken in 4.2?
  4. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    23 Aug 2011
    Link to this post
    Telerik? Any help on this? I have 25 sites running on 4.2 now and any of them that use multiple urls cause an infinite loop crash in IE.
  5. Mayvelous
    Mayvelous avatar
    43 posts
    Registered:
    26 May 2011
    23 Aug 2011
    Link to this post
    I think this might be related to my empty screens and page flickerings problem as well. I'll track your post too since nobody reply mine yet. http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/upload-documents-link-screen-becomes-empty.aspx
  6. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    23 Aug 2011
    Link to this post
    Hi May,

    What browser do you use to load the pages? Is it Firefox 6.0?

    All the best,
    Lubomir Velkov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  7. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    23 Aug 2011
    Link to this post
    This is happening in all browsers and the infinite loop is causing IE to crash. Chrome and Firefox detect the loop and kill the page request.
  8. Mayvelous
    Mayvelous avatar
    43 posts
    Registered:
    26 May 2011
    24 Aug 2011
    Link to this post
    I've tested with IE, FF 6, Chrome and all failing as Mark's mentioned.
  9. Mayvelous
    Mayvelous avatar
    43 posts
    Registered:
    26 May 2011
    24 Aug 2011
    Link to this post
    I just upgraded another site to 4.2 and all the pages are working except for one page; I can't view that page in the front-end as well as in admin > pages. It's a very simple static content page and don't understand why it gets the problem. I'm getting this on FF.

    The page isn't redirecting properly         
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    This problem can sometimes be caused by disabling or refusing to accept cookies.


    Any solution for this please?
  10. olav
    olav avatar
    76 posts
    Registered:
    22 Jan 2007
    24 Aug 2011
    Link to this post
    Hi all,

    I created a simple web mostly for testing v4, and performed an upgrade from 4.1 to 4.2 when I got this redirect loop trying to edit list items or templates (but not pages).

    Yes, it was Firefox 6.0, seems to work ok in IE 9.0.2.
    Anybody, please make a post when SF4 once again works with the latest FF. (although we would not start using SF4 for anything critical in a long time)
    Thanks!
  11. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    24 Aug 2011
    Link to this post
    @all

    Sorry wasn't the hotfix for 4.2 supposed to take care of the FF 6.0 problems.

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/sitefinity-4-2-hotfix-1.aspx

    Your Account
    Download and manage your products
    Download installer and other resources
    Browse all product files (to the right of big green button)
    Sitefinity 4.2 hotfix 1

    Regards Markus
  12. olav
    olav avatar
    76 posts
    Registered:
    22 Jan 2007
    24 Aug 2011
    Link to this post
    Thanks Markus, the hotfix took care of things. I had not noticed that one.

    This is another opportunity to ask/remind Telerik to add nice individual RSS feeds for updates of all their products, Sitefinity too. (yes, we have almost everything from Telerik, and most products have an RSS tag at the release notes page, feeding all releases and fixes)
  13. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    21 Jul 2017
    26 Aug 2011
    Link to this post
    Hi Olav,

    Thank you for the suggestion Olav we will make sure we use better way of anouncing new additions to releases. Currently the hotfix was announced in the general discussions forum with sticky thread. You can subscribe to receive feed from this forum because all announcements are made available there.

    Greetings,
    Stanislav Velikov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  14. ferdig
    ferdig avatar
    2 posts
    Registered:
    27 Sep 2007
    19 Sep 2011
    Link to this post
    Hi Mark,

    Did the hotfix fix your problem?
    I have just upgraded my application from 4.1 to 4.2 and having the same problem with the infinite loop.
    Also, after applying the hotfix, the problem still exists in both FF (6.x) and IE.

    @Telerik: any updates on this issue?

    Regards,
    Ferdi
  15. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    19 Sep 2011
    Link to this post
    @Ferdi

    Did you check if the pages redirecting indefinetly have extra URL added.
    Title and properties. And if they do, does removing them help ?

    Markus
  16. ferdig
    ferdig avatar
    2 posts
    Registered:
    27 Sep 2007
    19 Sep 2011
    Link to this post
    Thanks for your reply Markus.

    Yes, removing them helps.
    But I was wondering whether there is a better solution, because I want to keep my multiple urls.
    Or will this be fixed in 4.2 SP1?
  17. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    19 Sep 2011
    Link to this post
    @Ferdi

    This behavoir was introduced in 4.2 and yes I sure hope that Telerik will fix this bug in the upcomming SP.

    Because if you drag a page from one place to another the extra URL get added automatically (at least what it does in my project). This results in the error you mentioned.

    So at the moment if any of my clients drag a page to another place and back - the page will get into the loop.

    I for one do not call this a behavoir but a major bug. So I expect it to be fixed in 4.2 SP1. Every thing else would make me really wonder.

    Markus
  18. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    21 Jul 2017
    21 Sep 2011
    Link to this post
    Hi Ferdi,

    You can preserve multiple url`s that are different from the page url. If your page url is  "Test", remove additional url ~/Test and add other.

    Kind regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
18 posts, 0 answered