1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / 404 on the login page?

404 on the login page?

9 posts, 0 answered
  1. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    29 Jun 2010
    Link to this post
    I can launch the CTP from the Sitefinity program manager, but I can't just hit the page directly with a browser.

    I'm getting a 404 here: http://localhost/Sitefinity/Login?ReturnUrl=/sitefinity/

    Are there any unexpected settings in IIS6 I'd need to make to have it recognize the MVC-like URLs?
  2. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    29 Jun 2010
    Link to this post
    When I ask about special IIS settings, I mean aside from the Silverlight mime types.
  3. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    30 Jun 2010
    Link to this post
    Hello Connections Academy Developer,

    Thank you for using our services.

    When you created your website where did you create the website on? Did you create it on the standard FileSystem option or on IIS. If you have not created the website on IIS through the project manager then the website is not automatically added on IIS and will not exist on localhost/. This is so because now we ship the Project Manager with an integrated web server - eliminates the need for IIS on development environment.  There should not be any special IIS settings - we have extensionless urls by default in this version of Sitefinity. The project manager will create all needed configurations for the website on localhost when you add a website to IIS through the project manager.

    Make sure that you have enabled Anonymous Authentication and that you have handlers for the WCF services. You should check if you have a handler mapping for .svc and the type is System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    02 Jul 2010
    Link to this post
    Thanks Ivan, I'll give your suggestions a try and comment back.
  5. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    02 Jul 2010
    Link to this post
    Unfortunately, we have to use IIS for development. I set that up, and http://localhost/ gives me an "under development" page. That's fine. However, http://localhost/Sitefinity still gives me a standard 404 error.

    I set up the extentionless URL mapping as indicated here:

    And I saw the .svc extension mapped to the aspnet_isapi.dll in IIS. 

    Is there somewhere else I'm supposed to set that up? Is the /sf404.aspx step still relevant?


  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    05 Jul 2010
    Link to this post
    Hello Connections Academy Developer,

    I think I have mentioned that the extensionless urls are by default in Sitefinity 4.0. The sf404.aspx is a Sitefinity 3.x concept and is not relevant in this version. Can you try removing the sf404.aspx mapping?


    Sincerely yours,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    07 Jul 2010
    Link to this post
    Hi Rado,

    I've verified this problem still exists both with and without the /sf404.aspx mapping. http://localhost/sitefinity still is giving a 404. Any other thoughts?
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    08 Jul 2010
    Link to this post
    Hi Connections Academy Developer,

    I suggest that you should start from the very beginning with this installation. You could also tell us whether the problem persists if you run the project through the built-in server of our Project Manger or it exists only when you host it under IIS 6. You could also attach a screenshot of IIS Authentication and Application pool sections.


    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. prespsc
    prespsc avatar
    32 posts
    Registered:
    19 Apr 2010
    17 Aug 2010
    Link to this post

    I've had issues similar to this when using IIS6 compared to the Project Manager, that I have yet to resolve.  Could this possibly be an issue with IIS6 when compared to Cassini and IIS 7?

    http://stackoverflow.com/questions/956139/http-handler-works-using-cassini-but-not-with-iis-6

     

    If you follow some advice from Richard's post, you should be able to partially resolve this issue, http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/4-0-installation-quirks.aspx

9 posts, 0 answered