+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / 6.3.5018 Internal Build might has a huge bug!!!!

6.3.5018 Internal Build might has a huge bug!!!!

13 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    07 Feb 2014
    Link to this post
    http://www.sitefinity.com/developer-network/forums/bugs-issues-/6-3-5000-to-6-3-5018-navigation-gone

    http://www.marktold.com/screencast/sf_6_3_5018_grouppages.swf

    Unless I am mistaken - you might want to hold on before updating to the latest internal build.

    Markus

  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    07 Feb 2014
    Link to this post
    Okay okay, you don't have to spam every forum and g+ for every issue...just put in a ticket
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    07 Feb 2014 in reply to Steve
    Link to this post
    Dear Steve

    You get me wrong. Its not about me. Its about other who might me have bugs and are updating to the internal build. You know some might be working on the weekend and try it out. But thanks for knocking that over my head. 

     Why did I post it also on G+ - because I have noticed that the community somehow seems to be splitting up. G+, sitefinity forum, Partner forums and linked in.

    I was just stupid enough to update on a Friday evening before going of to 1 week of vacation because of some bugs I had. Now stay a bit longer.

    But you are right. I should have kept it for my self and let other figure it out the hard way.

    Glad you look out for all forum members. Have a good weekend!

    Markus

    BTW:
    - I did open a ticket :-) 
    - I did delete my post on G+ 
    - The reason I posted on two forums here is that
    ----> It seems to be a bug so in Bugs & Issues
    ----> It concerns internal builds with the thread in General Discussions

  4. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    08 Feb 2014
    Link to this post
    Thanks Markus for finding this bug.
    I am using 6.3.5017.0 PE and group pages are working fine. I was going to update to 6.3.5018 this weekend but saw your post.
    Creating ticket for bugs will not help others.
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    08 Feb 2014 in reply to Rabindra
    Link to this post
    Dear  Rabindra

    Thank's for your kind words of appreciation. Post title reads MIGHT has a bug.

    Unless this is confirmed it still could be a wired setup form my site, server or once again something I do wrong. If you go ahead and test it and update just make sure you have a backup of your database since downgrading is not possible.

    Markus
  6. Nayden Gochev
    Nayden Gochev avatar
    32 posts
    Registered:
    03 Nov 2014
    10 Feb 2014
    Link to this post
    Hello Markus,

    as I answered in another ticket as well indeed we introduced a bug with this hot fix and we really sorry for the incontinence . It will be fixed in the next release later this week. The problem is it requires a full regression testing of all cases with the navigation widget by several persons to be sure that everything is correct this time.
    So upgrade to this week version ones it is ready and your issue will be fixed we know it is high priority for everything it is quite serious bug and we are working on it as we speak.

    Regards,
    Nayden Gochev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  7. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 Feb 2014 in reply to Nayden Gochev
    Link to this post
    @Naydan

    Sorry for posting at verious places and thanks for fixing the bug.
    I always find it funny (since I am not native english speaking) when I read the term introduced a bug. 
    It's like you would introduce us. Bug - Markus, Markus - Bug. :-)

    @Rabindra
    Did you update now? And is it working?

    Markus
  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 Feb 2014 in reply to Markus
    Link to this post
    Dear Nydan

    The fix reads: Redirect pages are not visible in the Navigation Widget.

    My problem was that if I had a group page and a 'real' page under it it would not work. Has this been fixed as well?

    Markus
  9. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    18 Feb 2014 in reply to Markus
    Link to this post
    Actually Markus, for those of us who are native English speakers, even funnier was 'sorry for the incontinence' - LOL
  10. Milena
    Milena avatar
    75 posts
    Registered:
    15 Jul 2016
    18 Feb 2014
    Link to this post
    Hello,

    Sitefinity 6.3.5020 product version has been released that contains the fix of the problem with Navigation widget.

    Regards,
    Milena
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  11. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    18 Feb 2014 in reply to Milena
    Link to this post
    Dear Milena

    I know that 6.3.5020 was released. My question was does the fix mentioned

    QUOTE
    The fix reads: Redirect pages are not visible in the Navigation Widget.
    UNQUOTE

    Also include pages that are under group pages. Since this was my original problem. 
    So in other words are group pages  also redirect pages. Don't want to update again only to find out that redirect pages now are shown but if you have a group page and a regular page under it it will not show.

    Hope you understand what I mean.

    http://www.marktold.com/screencast/sf_6_3_5018_grouppages.swf

    Markus
  12. Milena
    Milena avatar
    75 posts
    Registered:
    15 Jul 2016
    19 Feb 2014
    Link to this post
    Hello Markus,

    Thank you for the additional information and recorded video!

    The problem has been fixed, I checked specified from you scenario.
    A screenshot of result test page is attached.

     If you have any further questions, do not hesitate to get back to us.


    Regards,
    Milena
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  13. Nick
    Nick avatar
    15 posts
    Registered:
    30 Oct 2013
    20 Feb 2014 in reply to MB
    Link to this post
    MB said:Actually Markus, for those of us who are native English speakers, even funnier was 'sorry for the incontinence' - LOL


    I have to admit I chuckled at this too!
13 posts, 0 answered