+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Adding Flash Content

Adding Flash Content

6 posts, 0 answered
  1. Falcon325
    Falcon325 avatar
    14 posts
    Registered:
    29 Sep 2007
    12 Feb 2013
    Link to this post
    Hi Guys, I'm having a problem visualizing a flash image rotator based on an XML file. I've created the Files folder to store the swf file. Question is, when I use the Content Editor and choose more formatting options and then choose the add flash button I can see the swf files I want to use. I then make all the necessary adjustments for size and save the modifications and close, after which I use preview to see if it's all good and low and behold, all I see is a blank object with a small black rectangle at the top left of the container and the word null. I've used this method in the past with 3.7, but I'm using 5.3 on a virtual machine, with Firefox. I've already verified the swf files by themselves in their folder, and there are aren't any problems. Wondering if SF, once it accepts the swf file in the content editor, that it breaks the path to the xml files.
  2. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    15 Feb 2013
    Link to this post
    Hello,

    Can you please verify that the application pool identity has read permissions for the folder where the XML files are placed? Additionally check if the paths from your flash application to your XML files are correct.

    Also you may want to take a look at this forum thread.
    http://www.sitefinity.com/developer-network/forums/bugs-issues/xml-driven-flash-movie-wont-play

    If you are still experiencing problems I would suggest to open a support ticket and send us the files.

    Regards,

    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Falcon325
    Falcon325 avatar
    14 posts
    Registered:
    29 Sep 2007
    18 Feb 2013 in reply to Pavel Benov
    Link to this post

    Ok, boys and girls, here's the solution I've found that seems to work, at least in my case. Using SF 5.3, apparently the api changes the path from /Files/swf.swf file to /ProjectNameFolder/Files/swf.swf file. So when you want to visualize the Flash object it must be seen using the "Live Site" option. Other than that, just make sure that if it's XML based, that the paths are all correct with regard to any image files you my be using. Lastly, this is the embed code I use:

    <embed width="940" height="400" flashvars="sloganRotatorXml=/BeachRugby/Files/xml/preview_1.xml" allowscriptaccess="always" quality="high" name="movie" id="movie" src="/BeachRugby/Files/preview_1.swf" type="application/x-shockwave-flash"></embed>

    This works for me. So if you're in need of an alternative there it is.

  4. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    21 Feb 2013
    Link to this post
    Hello,

    Thank you for sharing the information with the community. 

    Kind regards,
    Pavel Benov
    the Telerik team
  5. Falcon325
    Falcon325 avatar
    14 posts
    Registered:
    29 Sep 2007
    05 Mar 2013 in reply to Pavel Benov
    Link to this post

    Ok, now I have another problem, I know it's a path issue, but the flash object wont play on a child page, any ideas where to start looking to correct this problem. It plays correctly on the parent page ie. the following parameter work on the parent page, but not the child;

    <embed width="940" height="400" flashvars="sloganRotatorXml=/xml/preview_1.xml" allowscriptaccess="always" quality="high" name="movie" id="movie" src="/Files/preview_1.swf" type="application/x-shockwave-flash"></embed>





    <embed width="940" height="150" flashvars="sloganRotatorXml=/xml/slogan_rotator.xml" allowscriptaccess="always" quality="high" name="movie" id="movie" src="/Files/slogan_rotator.swf" type="application/x-shockwave-flash"></embed>

  6. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    08 Mar 2013
    Link to this post
    Hello,

    Have you tried to place the project's name folder in the .xml file reference?

    Xml=/BeachRugby/Files/xml/preview_1.xml"

    Kind regards,
    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered