+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Adding User Control "Could not load type 'SitefinityWebApp.Controls.xxx'"

Adding User Control "Could not load type 'SitefinityWebApp.Controls.xxx'"

5 posts, 1 answered
  1. Chris
    Chris avatar
    16 posts
    Registered:
    21 Jan 2011
    21 Feb 2011
    Link to this post
    I followed the instructions in the documentation word for word, and when I drag the control from the side bar to the page content editor, the error: "Could not load type 'SitefinityWebApp.Controls.xxx'" pops up.
    The user control is blank except for text, no extra logic -> created in visual studio, added text, that's it....
    ? Am I missing something, do I have to use a different base class than System.Web.UI.UserControl, or add some reference to the project? Totally lost one why this is happening when I followed the doc...
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Feb 2011
    Link to this post
    Hello Chris,

    Most probably the control has not been registered properly or you have not build the application after the changes you made.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Answered
  3. Chris
    Chris avatar
    16 posts
    Registered:
    21 Jan 2011
    21 Feb 2011
    Link to this post
    Had to rebuild the solution. Go figure :S  Thanks!
  4. Ofir
    Ofir avatar
    1 posts
    Registered:
    13 Jan 2012
    22 Feb 2012
    Link to this post
    use CodeFile='abc.ascx.cs' instead of CodeBehind='abc.ascx.cs' this will compile the file as it loads it
    http://stackoverflow.com/questions/73022/codefile-vs-codebehind 
  5. Mike
    Mike avatar
    1 posts
    Registered:
    28 Jun 2012
    08 Aug 2012
    Link to this post
    Thanks Ofir.  I am adding my control to a live site and can't build the solution. Was banging my head on this. Thanks again for the real world solution.
5 posts, 1 answered