+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / AjaxControlToolkit JavaScript resource not including after 4.1 upgrade

AjaxControlToolkit JavaScript resource not including after 4.1 upgrade

4 posts, 0 answered
  1. Eric
    Eric avatar
    147 posts
    Registered:
    12 Nov 2007
    20 Apr 2011
    Link to this post
    After upgrading to 4.1, I'm having a problem including the javascript from the AjaxControlToolkit. My homepage is called "home". I'm using the AjaxControlToolkit's ToolkitScriptManager in my masterpage/template. This worked in 4.0.

    The following script inclusion comes back as the html of the home page:
    /?_TSM_HiddenField_=ctl00_scriptManager_HiddenField&_TSM_CombinedScripts_=%3b%3bAjaxControlToolkit%2c+Ver...

    If I add "home" to the URL, the AjaxControlToolkit javascript comes back as expected:
    /home?_TSM_HiddenField_=ctl00_scriptManager_HiddenField&_TSM_CombinedScripts_=%3b%3bAjaxControlToolkit%2c+Ver...
  2. Eric
    Eric avatar
    147 posts
    Registered:
    12 Nov 2007
    22 Apr 2011
    Link to this post
    I fixed this by changing from the AjaxControlToolkit's ToolkitScriptManager to Telerik's RadScriptManager.

    I'd prefer to avoid them since we don't have full licenses for RadControls and it binds these controls to the SF project. However, it's more of principle thing since if I want to use the controls outside SF, I can use the ToolkitScriptManager in my other MasterPages.
  3. Keith
    Keith avatar
    8 posts
    Registered:
    25 Oct 2010
    15 Dec 2011
    Link to this post
    I was having this same problem but changing to the radScriptManager did not help me. What did fix this in my case was setting the CombineScripts="false" property on my ToolkitScriptManager. Hope this helps someone else...

    <cc1:ToolkitScriptManager ID="_scriptManager" runat="server" CombineScripts="false" />
    
  4. Steve
    Steve avatar
    1 posts
    Registered:
    14 Jun 2012
    10 Sep 2014 in reply to Keith
    Link to this post
    3 years later and you helped me out, thanks Keith!
4 posts, 0 answered