1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Beta 2: Theme css forbidden access

Beta 2: Theme css forbidden access

3 posts, 0 answered
  1. Glenn
    Glenn avatar
    2 posts
    Registered:
    02 Aug 2010
    06 Oct 2010
    Link to this post
    After installing 4.0 Beta 2, I created a new project and copied over all files from my custom theme that was working in Beta 1.

    I created the theme under Settings/Appearance/Frontend themes, and created 'My Theme', with the following value for Path: ~\App_Data\Sitefinity\WebsiteTemplates\MyTemplate\App_Themes\MyTheme

    Applying the theme didn't work, so I fired up Firebug to see if the css was being sent down to the browser.  Apparently there is some permissions issue:

    ...
    <link rel="stylesheet" type="text/css" href="/MyApp/App_Data/Sitefinity/WebsiteTemplates/MyTemplate/App_Themes/MyTheme/global/style.css">
    ...
    21 <h2> <i>HTTP Error 403 - Forbidden.</i> </h2></span>
    22
    23 <hr width=100% size=1 color=silver>
    24
    25 <b>Version Information:</b>&nbsp;Telerik Web Server 4.0.676.0
    ...

    Has something changed with security/permissions in Beta 2 that I need to address?

    Thanks.
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    06 Oct 2010
    Link to this post
    Hello Glenn,

    Thank you for using our services.

    The method of registering themes has not been changed.  From your message the only thing that seems odd is the path to the files. Can you make sure that you are using "/" instead of "\" slash?

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Glenn
    Glenn avatar
    2 posts
    Registered:
    02 Aug 2010
    06 Oct 2010
    Link to this post
    That was it!

    Thanks!
3 posts, 0 answered