1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / BuildProvider

BuildProvider

11 posts, 0 answered
  1. John
    John avatar
    6 posts
    Registered:
    15 Nov 2010
    19 Nov 2010
    Link to this post
    Hello,

    I just came from the version 3.7 and I'm trying to use a custom control that I used before mycontrol.dll but I got this message.

    What I need to do?

    Thanks in advance,

    John Camberos
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    19 Nov 2010
    Link to this post
    Hello John,

    Have you recompiled the control and added all needed references? Controls registration in Sitefinity 4.0 is different from this one used in 3.x

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. John
    John avatar
    6 posts
    Registered:
    15 Nov 2010
    19 Nov 2010
    Link to this post
    Hello Ivan,

    I did the control registration as shown on the tutorial and I still got the same result, I have try to create a new control (Hello World Control) the .ascx works perfect but I need to use as .dll and try the same control in .dll and I got the same message.

    Thanks
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    21 Nov 2010
    Link to this post
    Hi John,

    Could you try suggestions provided in these posts


    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. John
    John avatar
    6 posts
    Registered:
    15 Nov 2010
    22 Nov 2010
    Link to this post
    Hello Ivan,

    I try that solutions before and doesn't work, I'm getting the same message. Here is the screen shoot with the .ascx running and the .dll with the message

    I got the message intermediately I drag the control into the web.

    Thank in advance,
    John
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    22 Nov 2010
    Link to this post
    Hi John,

    Have you added BuildProvidersToAttribute in the machine or web.config? This error does not seem to be related to our code.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. John
    John avatar
    6 posts
    Registered:
    15 Nov 2010
    23 Nov 2010
    Link to this post
    Hey Ivan,

    I'm not really sure what is going on, but I used the control outside SiteFinity and is working, but I try to use it inside SiteFinity and I got that message.

    I have tried to uninstall and reinstall SiteFinity, also, I changed many time the web.config inside SiteFinity with no positive results.

    Regards,
    John
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    23 Nov 2010
    Link to this post
    Hello John,

    Could you sent a sample code that I can compile and see the issue locally? If you create  a class library and a class which inherits from CompositeControl and compile this to a dll ( without adding any other code) do you get the same error.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. John
    John avatar
    6 posts
    Registered:
    15 Nov 2010
    23 Nov 2010
    Link to this post
    Hey Ivan,

    I'm creating a new Project -> ASP.NET Server Control, I'm using the default code:

    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using System.Web;
    using System.Web.UI;
    using System.Web.UI.WebControls;

    namespace ServerControl
    {
        [DefaultProperty("Text")]
        [ToolboxData("<{0}:ServerControl1 runat=server></{0}:ServerControl1>")]
        public class ServerControl1 : CompositeControl
        {
            [Bindable(true)]
            [Category("Appearance")]
            [DefaultValue("")]
            [Localizable(true)]
            public string Text
            {
                get
                {
                    String s = (String)ViewState["Text"];
                    return ((s == null) ? "[" + this.ID + "]" : s);
                }

                set
                {
                    ViewState["Text"] = value;
                }
            }

            protected override void RenderContents(HtmlTextWriter output)
            {
                output.Write(Text);
            }
        }
    }

    I have tried inherit from CompositeControl also from WebControl with same results.

    I build the solution, and then I import the dll file to SiteFinity as shown on the tutorial.

    Thanks,
    John
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    23 Nov 2010
    Link to this post
    Hello John,

    Please take a look at the attached video where I used your class.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. John
    John avatar
    6 posts
    Registered:
    15 Nov 2010
    23 Nov 2010
    Link to this post
    Hey Ivan,

    That was a nice solution, but I was looking to import a .dll no to create a new project inside the project created by SiteFinity. Anyway, I found the solution, the problem was that my control has this namespace: my_control and the assembly name was: my control. When I add it to SiteFinity I used my_control that was the reason it was asking for the BuildProvider.

    Thank you for the help,

    Best regards,
    John
11 posts, 0 answered