1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Can I upgrade from 4.1 1339 to 5.0?

Can I upgrade from 4.1 1339 to 5.0?

10 posts, 0 answered
  1. Eric
    Eric avatar
    18 posts
    Registered:
    19 Jan 2011
    06 Mar 2012
    Link to this post
    Would I be able to upgrade straight from 4.1 to 5.0? That sounds like a big jump. If I need to upgrade to another version first, I'd like to find out.
  2. SVA Webmaster
    SVA Webmaster avatar
    85 posts
    Registered:
    18 Jul 2007
    06 Mar 2012
    Link to this post
    Eric,

    You can only go from 4.3 or 4.4 to 5.0, therefore you'd have to do successive upgrades until you are on 4.3 or 4.4 before going for 5.
  3. Eric
    Eric avatar
    18 posts
    Registered:
    19 Jan 2011
    06 Mar 2012
    Link to this post
    That doesn't sound too bad. Can I go from 4.1 to 4.4, then? Or do I have to upgrade to 4.3 first?
  4. SVA Webmaster
    SVA Webmaster avatar
    85 posts
    Registered:
    18 Jul 2007
    06 Mar 2012
    Link to this post
    It is my understanding that it's best to go through each iterative update to get to 4.4,
  5. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    07 Mar 2012
    Link to this post
    Hi Eric,

    In order to ensure that your project is properly upgraded, you may need to go through the major editions of Sitefinity 4.x before going to 5.0, due to the fact that in each version of Sitefinity there are significant changes, which if skipped, can break some of modules / functionality of the system. What I can suggest you is to go through 4.2, 4.3 and 4.4 before upgrading to 5.0.

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Thomas
    Thomas avatar
    223 posts
    Registered:
    19 Jan 2011
    07 Mar 2012
    Link to this post
    Hi Victor,

    Wouldn't skipping the 4.4 upgrade be a good idea, to avoid the content block corruption bug (trailing br tag added)? Although it's still unclear whether 5.0 fixes this issue.
    SF 4.2 SP1 also broke img tags, for the record.
  7. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    09 Mar 2012
    Link to this post
    Hi Thomas,

    There were major changes in Sitefinity 4.4 as well as a lot new functionality introduced so I would not recommend skipping it, despite the <br> tag in the content block that was found. As you know there are several workarounds for this bug, until we get it fixed.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    09 Mar 2012
    Link to this post
    @Victor
    Telerik clearly stats that you can upgrade from the 4.3 and 4.4. So I would expect skipping 4.4 should not be a problem

    Imagin how much work it is to take a 4.0 site up to 5.0. This is if you test the in between steps.

    Markus
  9. Thomas
    Thomas avatar
    223 posts
    Registered:
    19 Jan 2011
    09 Mar 2012
    Link to this post
    For clarity: I initially thought the br tag bug modified your database data as you upgrade your site, but the br tag is appended during display only (ie: the data in the database is not corrupted, and left as is).

    Therefore, it doesn't matter whether you skip 4.4 or not. And besides, the bug is not fixed in 5.0. But as Markus said, upgrading from 4.3 to 5.0 should work flawlessly, as officially stated by the Telerik team. If despite these claims there are known issues when upgrading from 4.3 to 5.0, then please let us know ASAP, because my team plans to do such upgrades soon.
  10. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    09 Mar 2012
    Link to this post
    Hello,

    Upgrading to 5.0 is indeed supported from 4.3, and this way the process works flawlessly. Mostly it is a matter of personal choice ( and free time ) to decide whether you want to go through 4.4 or not. However, you can be sure that upgrading from 4.3 to 5.0 is supported as stated in our documentation.

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
10 posts, 0 answered