+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Cannot configure new project (8.1.5820.0)

Cannot configure new project (8.1.5820.0)

2 posts, 0 answered
  1. Dan
    Dan avatar
    1 posts
    Registered:
    03 Sep 2015
    14 Oct 2015
    Link to this post

    I am trying to configure a new project and followed the wizard instructions. I opted for storing in the file system as I am on a Windows 7 machine and a previous FTP attempt failed.

    The project was created and I validated the license. But when I went to administration and it launched the local webserver in my browser I got: "Invalid root node configured for pages. No root node with the name of  "00000000-0000-0000-0000-000000000000"

    Can someone tell me where I need to change this or is there another option I need to take?

    Thanks

    Dan

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    05 Dec 2016
    19 Oct 2015
    Link to this post
    Hi Dan,

    The issue may occur if Sitefinity is not able to connect to its database or it is trying to connect to a database which is not the original database which the project has been created with. So, can you please go to ~/App_Data/Sitefinity/Configuration and open the DataConfig.config file in order to make sure that there is a connection string with name="Sitefinity" and it is pointing to the correct database.

    You may also refer to the following KB article which may be also helpful:

    http://www.sitefinity.com/developer-network/knowledge-base-old/when-sitefinity-project-is-deployed-to-production-server-an-invalid-root-node-configured-for-pages-no-root-node-with-the-name-of-frontendsitemap-error-is-thrown

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered