+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Cannot disable comments

Cannot disable comments

9 posts, 0 answered
  1. Nancy
    Nancy avatar
    35 posts
    Registered:
    10 Apr 2012
    21 May 2012
    Link to this post
    Is there any way to completely disable comments site-wide? I am trying to turn them off on an item by item basis, but it is not working. I went into the Settings >Basic > News > Comments Settings and set AllowComments to False. I have saved the changes, but I am still seeing the comments form on individual news articles when I open an article in a browser where I am not logged in to the site at all. Is there another setting overriding this? Thanks for any help you can give.
  2. Tim
    Tim avatar
    258 posts
    Registered:
    22 Jun 2011
    21 May 2012
    Link to this post
    Nancy,

    When I make administration changes that don't apply as immediately as I'd hoped, restarting everything helps.

    You can try making a small change to the web.config, saving it, then refresh the page that you were looking at.
  3. Nancy
    Nancy avatar
    35 posts
    Registered:
    10 Apr 2012
    21 May 2012
    Link to this post
    Hi Tim,
    That sounded like a logical idea. I tried it and it did not work. I am attaching a screeshot that shows what I see as a non-logged-in visitor to the site on the left side of the screen and the news comments settings in the admin interface in the right. Any ideas?
  4. Tim
    Tim avatar
    258 posts
    Registered:
    22 Jun 2011
    21 May 2012
    Link to this post
    Nancy,

    Well, there is another Comments setting in Administration -> Settings -> Advanced -> Comments -> Comments Settings. If you scroll to the bottom, you'll see "AllowComments". Setting that to "False" should do the trick! :)
  5. Nancy
    Nancy avatar
    35 posts
    Registered:
    10 Apr 2012
    21 May 2012
    Link to this post
    D'oh! The comment form is still showing up. I went to Admin > Settings > Advanced > Comments Settings and made sure that "AllowComments" is set to False and saved even though I didn't really change anything. Then I did a quick edit to web.config and saved it. When I reload  or navigate to any of the other news article pages, I still see the comment form. In settings, the checkboxes for "DisplayNameField", "DisplayEmailField" are all unchecked, yet they are showing on the form.

    And, my comment config :
    <commentsConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="5.0.2860.0">
        <commentsSettings displayNameField="False" isNameFieldRequired="False" displayEmailField="False" displayWebSiteField="False" displayMessageField="False" isMessageFieldRequired="False" postRights="RegisteredUsers" allowComments="False" />
    </commentsConfig>
  6. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    02 Jul 2014 in reply to Nancy
    Link to this post

    This is happening to me also (version 6.3). How do I completely turn off comments? I've even deactivated the comments module and that hasn't done anything.

  7. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    03 Jul 2014
    Link to this post
    Hello all,

    Could you please check the pages where the comments widget appears and whether or not it is active? If the module is deactivated it should show a message saying so, and to not show up in the front-end. After uninstalling the module, the widgets should disappear completely, removing it from the widgets toolbox and not making possible to add them on a page.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  8. richstrickland
    richstrickland avatar
    2 posts
    Registered:
    28 Mar 2014
    22 Jan 2015
    Link to this post

    So this has been plaguing a client of mine in v7+.  On finally digging down I have found out how to turn this off but it is BURIED!

    from main dashboard in backend, go to content->news; then under "Manage also" comments for news on right hand side (rhs), click that then click "Settings" when rhs reloads under "Settings for comments" then expand "commentable types" under the left hand side tree that appears and click "Telerik.Sitefinity.News.Model.NewsItem". Uncheck "Allow Comments" then save.

     Note to Sitefinity - I love the granularity.. hate that it's so buried :P

  9. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    22 Jan 2015
    Link to this post
    Hi,

    This will disable comments for a specific type, not the comments module itself. Those settings are also available from Administration -> Settings -> Advanced -> CommentsModule -> Commentable types.
    Information how to turn on/off comments per type is provided in this documentation article.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
9 posts, 0 answered