+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Cannot reindex search index

Cannot reindex search index

24 posts, 0 answered
  1. MJia
    MJia avatar
    44 posts
    Registered:
    09 Jun 2009
    14 Jan 2011
    Link to this post
    I got error when trying to reindex a search index.  I attached screen shot.

    Please help.
    Thanks.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jan 2011
    Link to this post
    Hello MJia,

    We know about this issue and we have logged a bug about it that will be fixed in our of the next builds.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    07 Feb 2011
    Link to this post
    Ivan,

    I have a couple of search related questions:
    1 - When searching a site, does the search look through documents in the library?
    2 - Can you make it search through the content on documents in libraries?

    Thank you,
    Andrei
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    07 Feb 2011
    Link to this post
    Hi Andrei,

    The Documents & Files module is not included in the index.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    07 Feb 2011
    Link to this post
    Ivan,

    Thanks. Would you have any suggestions as to a work-around at all? Is this something Sitefinity is looking at for the future?

    Many thanks,
    Andrei
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    07 Feb 2011
    Link to this post
    Hello Andrei,

    I am not able to provide you with a workaround, but we have plans to index documents and file content. We have logged task for this - ID - 106997, but currently we have not estimate it.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Michael
    Michael avatar
    59 posts
    Registered:
    02 Nov 2010
    15 Feb 2011
    Link to this post
    I am getting this error also and therefore search does not work for me, it always is returning 0 results.  Even when i create a brand new index it doesn't seem like it is working in general.   What does the search base its results off of?  Do i need to add keywords and meta data to every single page?
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    15 Feb 2011
    Link to this post
    Hello,

    Most probably the index is not configured properly. If you want to get data from pages, make sure that Static HTML checkbox is checked.

    The PagePipe looks for

    • Content
    • Keywords
    • GetFullUrl - full url
    • Description
    • Title

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Vincent
    Vincent avatar
    41 posts
    Registered:
    21 Sep 2007
    21 Feb 2011
    Link to this post
    Hi,

    I am having quite the same problem when reindexing indexes.
    I get a Return 0 message or this message :
    Could not find a part of the path 'E:\web\asalogcom00\htdocs\App_Data\Sitefinity\Search\all\
    The site www.asalog.com is hosted at DiscountASP.net.
    Sitefinity version is 4.0.1098
    I have set up the scope as Static HTML and Blog Posts

    Regards
    Vincent
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Feb 2011
    Link to this post
    Hello Vincent,

    Please recreate your index. The error says that the files related to the index are missing.

    Could not find a part of the path 'E:\web\asalogcom00\htdocs\App_Data\Sitefinity\Search\all\

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  11. Vincent
    Vincent avatar
    41 posts
    Registered:
    21 Sep 2007
    21 Feb 2011
    Link to this post
    Hello Ivan,

    Thank you for coming back to me.

    The error message is thrown when I reindex, and yes, I can see that the files are never created.

    Vincent
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Feb 2011
    Link to this post
    Hi Vincent,

    I am not able to replicate this issue locally. Can you try to install a new project with the Project Manager, run the project through the built-in web server and try to index?

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  13. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    08 Mar 2011
    Link to this post
    Hi,

    I have the same issue, I created a news index, I am trying to re-index it but I got "Exception has been thrown by the target of an invocation" (as shown in the attached screenshot)

    Also, when I created a testing page with the search control, and I am searching with a word in one of the news items, I got "0 searching results".

    I am using version 4.0.1210.0

    Thanks.
  14. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    08 Mar 2011
    Link to this post
    Thanks I resolved the issue.
  15. Ray
    Ray avatar
    9 posts
    Registered:
    17 Mar 2011
    25 Mar 2011
    Link to this post
    Andre, PDF search was very important to one of our clients. We are working with a workaround by putting the PDFs in a subdomain on a web server and storing them all there.  Then adding Google Search targeted on that directory.  We call it an "Advanced Search." 
  16. Nikolay Datchev
    Nikolay Datchev avatar
    87 posts
    Registered:
    01 Nov 2016
    30 Mar 2011
    Link to this post
    Hello,

    Just wanted to recap on the re-indexing errors - does anyone in the thread still has problems with that. If so please check if the user that your web application pool is using has permissions to create and modify files in this App_Data sub folder.

    About the indexing of documents and libraries we still don't have official estimate for the inclusion of this feature in Sitefinity.

    Kind regards,
    Nikolay Datchev
    the Telerik team
  17. Michael
    Michael avatar
    59 posts
    Registered:
    02 Nov 2010
    01 Apr 2011
    Link to this post
    Hi

    I have confirmed that the app pool user has full access to the app_data and all subfolders including the search folder.  When i do a re-index in the backend i can watch the folder get deleted and recreated and then the same error gets thrown in the backend "Exception of type 'System.Web.HttpUnhandledException' was thrown."

    And it doesn't index my content.
  18. Vincent
    Vincent avatar
    41 posts
    Registered:
    21 Sep 2007
    01 Apr 2011
    Link to this post
    Hi,

    The problem for me has been solved by increasing quota for Anonymous ASPNet User on discountasp.net :
    default value is 100 MB has been changed to 200.
    The problem I had was that all files in the search folder were deleted and cannot be recreated leaving an empty folder.
    I had to recreate indexes on my dev computer and copy then to the site.

    Regards
    Vincent
  19. Sham
    Sham avatar
    27 posts
    Registered:
    08 Dec 2010
    12 Apr 2011
    Link to this post
    Hi,

    i tried all the ways that are mentioned in this post but i am still facing the error "Exception of type 'System.Web.HttpUnhandledException' was thrown."

    i commented my code using session object, added enablesessionstate, given access permission for App_Data folder to the user i am using in app pool but no luck. i am using Windows 7 and ISS 7.


    thanks in advance for the help.

    Sham
  20. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    12 Apr 2011
    Link to this post
    Hello,

    Do you have RadStylesheet manager or RadScriptManager in the template? This could also cause the error you are getting.

    Greetings,
    Ivan Dimitrov
    the Telerik team

  21. Sham
    Sham avatar
    27 posts
    Registered:
    08 Dec 2010
    12 Apr 2011
    Link to this post
    No I don't have RadStylesheet Manager or RadScript Manager in the template
  22. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    12 Apr 2011
    Link to this post
    Hi ,

    Then the problem is in some of your custom controls. Can you replicate the issue on a new installation of Sitefinity ? It looks like you have not escaped all places where you use the page object, SiteMap or session.
    If the problem persists, you can open a support request and send the project and its database to us.

    Regards,
    Ivan Dimitrov
    the Telerik team

  23. Vakeel
    Vakeel avatar
    19 posts
    Registered:
    13 May 2014
    18 May 2015 in reply to Ivan Dimitrov
    Link to this post

    Hi Ivan,

    I am using sitefinity 7.3 I getting error Object Reference message ,I am reading lots of forum  to resolve it even I try to recreate index but it still giving me error when i am going to Reindexing it

    please reply me as soon as possible 

     

  24. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    06 Dec 2016
    21 May 2015
    Link to this post
    Hi,

    For this error to occur the site may not have permissions to write the search index file in App_Data/Sitefinity/Search folder. Please make sure to grant read,write, modify permissions over App_Data/Folder, this requirement is part of this documentation article.

    If this doesn`t solve the problem please replicate the error and then go to App_Data/Sitefinity/Logs folder and locate the Error.log and Trace.log, locate the Object Refence error and paste the full error to get get more detailed info on the problem.

    Regards,
    Stanislav Velikov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
24 posts, 0 answered