1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Charity Database version

Charity Database version

4 posts, 0 answered
  1. KMac
    KMac avatar
    133 posts
    Registered:
    15 Dec 2008
    18 Jan 2011
    Link to this post
    Hello,

    Just trying to set up the Charity Starter Kit to play around with it but I get this error:

    cannot be opened because it is version 661. This server supports version 655 and earlier. A downgrade path is not supported.

    I'm assuming that's because the database is SQL 2008 R2. Is express version of the starter kits? Or am I just doing something wrong because it's time to go home?
  2. Preetham Reddy
    Preetham Reddy avatar
    57 posts
    Registered:
    16 Jul 2012
    19 Jan 2011
    Link to this post
    Do you have SQL Sever 2008 R2 installed??

    If yes, Navigate to ~/App_Data/Sitefinity.mdf and attach it to the database. Create a new user, make him owner of sitefinity database that you just attached...

    Got to SecurityConfig.config and change the connection string to point to the new database...

    That should solve it....

    Have a look at the FAQ here....

    http://Sitefinity.com/givecamp
  3. KMac
    KMac avatar
    133 posts
    Registered:
    15 Dec 2008
    19 Jan 2011
    Link to this post
    Hey Preetham,

    Thanks for the info. That's the problem though, I don't have R2 installed on my dev box and not ready to install it so was wondering about an express edition.
  4. Matthew
    Matthew avatar
    3 posts
    Registered:
    10 Jan 2011
    20 Jan 2011
    Link to this post
    I think the config file you want to change is DataConfig.config.. Not SecurityConfig.config.

    DataConfig contains the connection string to the database.

    Matt
4 posts, 0 answered