+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Configuring LDAP

Configuring LDAP

8 posts, 0 answered
  1. Eric
    Eric avatar
    18 posts
    Registered:
    19 Jan 2011
    16 Jun 2011
    Link to this post
    Hi Sitefinity,

    I've entered in our domain's values for the LDAP settings. I'm not clear of whats supposed to happen next. Does it start populating the user list automatically, or do I click a button to do that?

    And how do I map Sitefinity roles to AD groups?

    Thanks!
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    17 Jun 2011
    Link to this post
    Hello Eric,

    I believe you might find this page of our Documentation useful,  especially the Configuring LDAP settings and Enabling Windows Authentication to automatically access Sitefinity backend articles.

    Also please visit the following forum thread which also contains valuable information which might be helpful to you.

    Best wishes,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Eric
    Eric avatar
    18 posts
    Registered:
    19 Jan 2011
    17 Jun 2011
    Link to this post
    Those articles helped alot. I hadn't seen those before. I'm still having trouble, though. What I'm seeing is that I enter all the settings, but no AD users show in the Users page under Administration. When I set the web.config to:
    <authentication mode="Windows"/>

    I'm not able to login after that. It says Parameter name windowsIdentity.Name error.

    This needs to resolved soon. We're trying to go into production for the first time today. It would have been convenient to have a way to test the settings to make sure they're working.
  4. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    21 Jun 2011
    Link to this post
    Hi Eric,

    We throw this error Invalid full name format.", "windowsIdentity.Name" when the windowsIdentity.Name is not in format Domain\USER. I am not able to replicate this issue locally with LDAP and Windows authentication. Can you check what the the identity name?

    System.Web.HttpContext.Current.User.Identity.Name

    also

    Windows Authentication should be set to on.
    Site/Sitefinity/Services - Windows Authentication should be off and Anonymous Authentication should be on.

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Shawn
    Shawn avatar
    1 posts
    Registered:
    18 Mar 2011
    21 Jun 2011
    Link to this post
    I'm also having some trouble configuring LDAP for Sitefinity.  I tested the connection and user DN filter in AD and it shows what I'm looking for... however I can't seem to get anything to display when I view Users for my LDAP provider.  Is there a good way to debug this to see where it's going wrong?
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    22 Jun 2011
    Link to this post
    Hi Shawn,

    Sitefinity is reader for the LDAP and it is hard to debug this. If you use a third party tool to test the LDAP settings can you see the users correctly.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    22 Jun 2011
    Link to this post
    Shawn,
    I was having similiar issues. I was able to find some errors in the error log. Look for it in your project file under App_Date\Sitefinity\Logs\Error.log . I my case I was trying to use domain/username for the login and it had to be just username. It told me it was invalid credentials so I could move on from there. Hope this helps.
  8. Vakeel
    Vakeel avatar
    19 posts
    Registered:
    13 May 2014
    11 Mar 2015
    Link to this post

    Hi ,

    I am using sitefinity 7.2 version .How to access Backend Sitefinity page without login prompt. My client requirement he want  that  he should  access backend pages on valid user (Window Authentication)

     please reply me as soon as possible

8 posts, 0 answered