+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Custom module not install on Sitefinity 5 SP1

Custom module not install on Sitefinity 5 SP1

3 posts, 1 answered
  1. Onur
    Onur avatar
    9 posts
    Registered:
    30 Jul 2012
    02 May 2012
    Link to this post
    Hi All,

    I tried to install custom module but pages are never install on backend. I put debug point on module project but debug points entered only initilize method not enter install method. Then I tried to copy sample Agents module project from Real Estate Starter Kit to inside my project. But it was same, nothing changed. Debug point only enter  public override void Initialize(ModuleSettings settings) method.
    How to install custom module on Sitefinity 5 Sp1  or how to trigger Install method.         public override void Install(SiteInitializer initializer)

    Please Help me, I need to create some custom modules.

    Thanks for your help.




  2. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    02 May 2012
    Link to this post
    Hi,if the Initialize method is called, but Install method is not it means that Sitefinity has already installed the module; though there may have been problems. If you want to trigger Install method again, you can do following:

    • In your project, open the App_Data/Sitefinity/Configuration/SystemConfig.config
    • Locate your module under the <applicationModules> node
    • Remove the version attribute of your module 
    • Restart the application pool
    • Set a break point on the Install method of your module
    • Run the website again in debug mode

    I hope this helps.

    Kind regards,
    Ivan
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  3. Onur
    Onur avatar
    9 posts
    Registered:
    30 Jul 2012
    02 May 2012
    Link to this post
    Thank you Ivan, it works like charm :)
3 posts, 1 answered