+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Custom referencing module searching in Sitefinity 7.2

Custom referencing module searching in Sitefinity 7.2

2 posts, 1 answered
  1. Tabish Usman
    Tabish Usman avatar
    25 posts
    Registered:
    27 May 2011
    13 Mar 2015
    Link to this post

    I am having problems in custom module search.
    In my case I have a custom module “brand” with fields shown in Image. (See brandModule.png)

    In this module there are two fields (Category, Subcategories) which are causing problem because when I delete those fields everything started working fine.

    These two fields actually referencing another module (both fields reference the same module) which is “Category” with fields as shown in the image. (See CategoryModule.png)

    In this module there is a field ParentCategory which is referencing the same module(it self).
    Now I have created a searchIndex as shown in the image. (See MySearchIndex.png)

    I have selected the “brand” module to and set its default page where the brands are published.

    After that when I try to search any of these brand items I don't find any.  

  2. Tabish Usman
    Tabish Usman avatar
    25 posts
    Registered:
    27 May 2011
    16 Mar 2015
    Link to this post

    After spending a lots of time, finally I found the actual problem, The actual problem was with the field Name ("Category") in the "brand" module because I think this field name is already reserved for module's default field names, this is why search index not indexing the brand modules items.
    Hope this may help others as well.

    Answered
2 posts, 1 answered