1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Error after upgrading 4.2 to 4.4

Error after upgrading 4.2 to 4.4

5 posts, 0 answered
  1. Erik
    Erik avatar
    10 posts
    Registered:
    01 Nov 2011
    10 Feb 2012
    Link to this post

    Server Error in '/ABPWebShop44' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Could not load file or assembly 'Telerik.Sitefinity.Utilities, Version=4.2.1650.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) (C:\ABP Webshop\ABPWebShop44\web.config line 107)

    Source Error: 

    Line 105:      <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI"/>
    Line 106:      <add name="SitefinityAnalyticsModule" type="Telerik.Sitefinity.Analytics.Server.DependencyResolution.Module.DependencyRegistrarHttpModule, Telerik.Sitefinity.Analytics.Server.DependencyResolution"/>
    Line 107:      <add name="SitefinityAtompubModule" type="Telerik.Sitefinity.Security.SitefinityAtompubModule, Telerik.Sitefinity"/>
    Line 108:    </httpModules>
    Line 109:  </system.web>

    Source File: C:\ABP Webshop\ABPWebShop44\web.config    Line: 107 


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
     
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    16 Aug 2017
    14 Feb 2012
    Link to this post
    Hi,

     Thank you for contacting us.

    The upgrade was not completed sucessfully. The upgraded project still referenced Sitefinity 4.2.1650 assemblies. To upgrade to 4.4 fist upgrade from 4.2.1650 to 4.3.1885 which is part of the official upgrade path.

    If the project is still refering to the old assemblies even after the upgrade:

    Parser Error Message: Could not load file or assembly 'Telerik.Sitefinity.Utilities, Version=4.2.1650.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest
    1.Create new project on Sitefinity 4.3.1885 and copy the contents of its bin folder to a newly created folder on the hard disk.
    2. Remove all references from your 4.2.1650 project (open the project in visual studio and remove all under references.)
    3. Right click References and then Add Reference... 
    4. Get reference to all assemblies from the folder created in step 1.
    5.Build the project in visual studio (F6) and start it. 
    6. The project should be upgraded without a problem

    Login to the backend and if all is ok follow the same steps to upgrade from 4.3.1885 to 4.4.2117
    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. readonlychild
    readonlychild avatar
    67 posts
    Registered:
    26 May 2011
    15 Feb 2012
    Link to this post
    Hello Stanislav,
    where can I see the "official upgrade path" you mention? ,
    I want to upgrade a site from 4.0 to 4.4


  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    16 Aug 2017
    16 Feb 2012
    Link to this post
    Hello,

     The path is published as a forum thread in General discussions forum section as a sticky thread. You can see the last release release notes here as well as the supported upgrade path to 4.4 "Supported Upgrade Paths: from Sitefinity 4.2 SP1 and 4.3. Older versions should be upgraded to one of these first."
    To upgrade 4.0 upgrade to 4.1.1339->4.1.1574(Sp3 or some of the other service packs)->4.2.1650->4.3.1885->4.4.2117. After upgrading the project run the project to perform database upgrade.

    Regards,

    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    16 Feb 2012
    Link to this post
    Dear Stanislav
    Look at the upgrades you hvae to make to get to 4.4 :-(
    5 Upgrades to lift 4.0 up to 4.4
    Lucky for those on 3.7 they can migrate in one step :-)
    I have written this before but i sure hope that in the future upgrads will be possible more then 2 versions back. Otherwise if you running 20 site it will be so much extra work to keep SF upto date.
    If this is the case many might consider leaving the SF at an older verision and not updating the yearly renewal fee - and telerik looses money.

    So please think about it if you have just 5 sites on 4.0 how much work this is to lift it up to 5.0 by the end of the month.

    Markus
5 posts, 0 answered