+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Error on creating new project

Error on creating new project

7 posts, 0 answered
  1. Jozsef Marmarosi
    Jozsef Marmarosi avatar
    3 posts
    Registered:
    01 Nov 2002
    05 May 2010
    Link to this post
    When I try to create a new project, I got the following error:

    FileNotFoundException:
    Could not load file or assembly 'Sitefinity_4_0_346, Version=4.0.346.0, Culture=neutral, PublicKeyToken=...' or one of its dependencies. The system cannot find the file specified.
    ...(trace)

    Any idea?

    Regards,

    Jozsef
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 May 2010
    Link to this post
    Hello Jozsef Marmarosi,

    Could you check whether you have Telerik.Sitefinity.dll version 4.0.346.0 in your bin folder and your project has reference to it.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jozsef Marmarosi
    Jozsef Marmarosi avatar
    3 posts
    Registered:
    01 Nov 2002
    05 May 2010
    Link to this post
    Hi Ivan,

    The .dll is in the _EmptyProject/bin folder, however the templates are not copied to Projects/NewProject folder. My previous actions that may cause the problem:
    First time I tried to create a new project, I selected Sql Server, however, I have entered a wrong SQL Server instance, and the project setup produced an unhandled exception. I restarted everything, and since then I got this error on creating new project.

    Jozsef
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 May 2010
    Link to this post
    Hi Jozsef Marmarosi,

    There is a knows issue when you initially you type wrong database server details and then try to install the project without restarting the Project Manager. I suggest that you should start from the very begging   - delete the project that has been created through the Project manager. Check whether any files has left in the installation directory  - if there are any, remove them. Then try to install a new project.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Jozsef Marmarosi
    Jozsef Marmarosi avatar
    3 posts
    Registered:
    01 Nov 2002
    05 May 2010
    Link to this post
    Hi Ivan,

    That fixed the problem, when I deleted _EmptyProject folder as well.

    Thanks for your help.

    Jozsef
  6. mattc
    mattc avatar
    105 posts
    Registered:
    11 Aug 2007
    16 Jul 2010
    Link to this post
    Yes this just happened for me too. Need to delete the _EmptyProject folder, good trick :)
    M
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 Jul 2010
    Link to this post
    Hi mattc,

    The issue will be fixed for the BETA.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
7 posts, 0 answered