+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / FrontEndLoginPageUrl Not Redirecting

FrontEndLoginPageUrl Not Redirecting

5 posts, 0 answered
  1. Xian
    Xian avatar
    18 posts
    Registered:
    03 Oct 2014
    16 Jan 2015
    Link to this post

    On version 7.3.

    I've set this up and it's worked fine in the past, but it was with a site with a configuration I couldn't even begin to recreate.  Here are the steps I took, can anyone tell me what's missing?

    1. Create & setup a fresh site.
    2. Create and publish 2 pages: landing & login
    3. Set page permissions for all pages to view by Authorized only.
    4. Override pages permissions for login and set to view by Everyone.
    5. Set (Advanced > Project > Default Site) FrontEndLoginPageUrl to ~/login. [tried various absolutes; other site used relative w/ success]
    6. Browse to /landing in an incognito window
    7. Page is redirected to Auth Service page. (/Sitefinity/Authentication/SWT)

     What setting(s) could I be missing to allow this to work properly?  My next step is to override during bootstrap, but I'd like to know if there's something I'm missing to make this core feature not work.

    Thanks!

  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    16 Jan 2015
    Link to this post
    Is this the problem where you have to edit the login widget and set the default page or landing page property (can't remember what it was called)?
  3. Xian
    Xian avatar
    18 posts
    Registered:
    03 Oct 2014
    16 Jan 2015 in reply to Steve
    Link to this post

    This should be that.  In my previous implementation of this, I did not use a Sitefinity Login widget, I made a custom widget with a button that redirected the user to an auth service.  There wasn't any widget magic required for the system to redirect unauthorized requests to a different page.

     

  4. Xian
    Xian avatar
    18 posts
    Registered:
    03 Oct 2014
    16 Jan 2015
    Link to this post
    The problem is that in order for FrontEndLoginPageUrl to work, the Multisite module cannot be enabled.   This should be added to the documentation either on the screen or the Frontend login page documentation.
  5. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    02 Dec 2016
    21 Jan 2015
    Link to this post
    Hello Christian,

    In order to set the login page where the users to be redirected when they access a restricted page in a multisite mode, please perform the below steps:
    1. Expand the selector in the upper-left corner of the page and click Manage sites.
    2. Click the Actions button of the site and in the dropdown menu, click Properties.
    3. Expand Advanced section.
    4. Under Address for public users login, select Select a page… radio button, click Select a page button and select the frontend login page.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
5 posts, 0 answered