+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / How do you clear cache

How do you clear cache

7 posts, 0 answered
  1. Ryan Dailey
    Ryan Dailey avatar
    41 posts
    Registered:
    08 Mar 2010
    30 Jun 2011
    Link to this post
    I updated one of my templates, but the changes are not being reflected in my page.  I have "No Caching" set on all of my page so I'm not sure what's going on.  Can someone tell how you clear the cache?  I've restarted the web server and still no change.
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    22 Sep 2016
    05 Jul 2011
    Link to this post
    Hello Ryan,

    There are few options to do this.
    Can you, please, try setting your caching profiles or disable caching at all by going to Administration->Settings->Advanced->Pages and inform me if the issues you are experiencing still persist? Also caching is disabled at Administration -> Settings -> Advanced -> System -> Output Cache Settings and disabled EnableOutputCache and EnableClientCache.
    Following the above steps you should make an edit in your theme css and it should appear when you edit a page and not on the frontend. As caching is disabled and the browser still have some previous css loaded it will not display the changes republishing the page and making further changes to css displays them as they are made as now the right css is cached in browser.
    If you are using hardcoded links to css files (for example in master pages) they might not get properly cached too so <link rel="stylesheet" type="text/css" href="/css/test1.css?t=633543081724531250" /> you can add a fake parameter after the css file name.
    The problem is not directly connected with Sitefinity because no caching usually results in such problems in most browsers.
    Also IIS reset will apply the changes in your css. This might also be useful.
    You can force the styles to be allied by putting this code in the code behind file of a web form:
    var pages = Telerik.Sitefinity.App.WorkWith().Pages().Get();
    Telerik.Sitefinity.Data.CacheDependency.Notify(pages.ToArray());
    Additionally making a simple change in the css should get applied when page is republished if you have the above settings in Administration ->Settings.

    Best wishes,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Anthony
    Anthony avatar
    108 posts
    Registered:
    29 Sep 2008
    14 Jul 2011
    Link to this post
    do these settings still apply in 4.1 sp2? 

    Can you, please, try setting your caching profiles or disable caching at all by going to Administration->Settings->Advanced->Pages and inform me if the issues you are experiencing still persist? Also caching is disabled at Administration -> Settings -> Advanced -> System -> Output Cache Settings and disabled EnableOutputCache and EnableClientCache.

    I see the settings mentioned in Administration -> Settings -> Advanced -> System -> Output Cache Settings but the ones in Administration->Settings->Advanced->Pages do not exist after upgrading to sp2.

    Anthony
  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    22 Sep 2016
    18 Jul 2011
    Link to this post
    Hello Anthony,

    Excuse me it is my mistake what I have referred to are the caching option on pages accessed trough Titles and properties of a page. Pages tab Actions -> Title & Properties.

    Best wishes,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Trevor
    Trevor avatar
    35 posts
    Registered:
    28 Jan 2012
    16 Feb 2012
    Link to this post
    I'm having the same issue in 4.3 -- i've disabled cacing in  Administration -> Settings -> Advanced -> System -> Output Cache Settings but i'm still gettin an error about a template location setting that i've changed.  after saving a new template file and adjusting control settings how can i tell sitefinity to look for a new setting?
  6. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    22 Sep 2016
    21 Feb 2012
    Link to this post
    Hello,

     Clear the browser cache too. And try to request the page where the template is, the cached path should be gone now. If you had cache enabled when Sitefinity was using output caching the browser may have cached the template and you still might be getting the cached version. To check if this is the case examine the request to this template with firebug or other tool for monitoring network requests and see the status code for returning the template. Clearing the browser cache have to take it with status code 200 and after this when it is cached by the browser the code will be 304. refer to this image.

    Kind regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Trevor
    Trevor avatar
    35 posts
    Registered:
    28 Jan 2012
    10 Mar 2015
    Link to this post

    Has anyone found a solution to this in SF 4.x?

    Ryan asked a question about how to clear the site cache so changes made in parent templates are propagated through to all pages using said templates, but Stanislav is only giving information about how to clear the CSS cache.

    Does anyone have an answer to the original question? If I have 400 pages that use 3 templates, and each of the 3 templates have the same single parent, then how do I make changes to that 1 parent template affect all 400 pages. 

    Currently, it seems that the only way to do this is to re-publish each page.

7 posts, 0 answered