+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / inline edit does not work - version 5.1

inline edit does not work - version 5.1

9 posts, 1 answered
  1. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
    22 Aug 2012
    Link to this post
    Does it require a special configuration somewhere? How do I make it work? Watched the video, it does not say that anything has to be configured... Logged in as an admin...
  2. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    22 Aug 2012
    Link to this post
    What do you mean by 'does not work' ?

    When you click on the Tools icon, and then click on 'Show editing tools', you should see buttons where you can edit content.

    If some custom widgets/controls are not offering in-line editing options, then perhaps they don't include the required support code for the BrowseAndEditToolbar
  3. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
  4. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    23 Aug 2012
    Link to this post
    Certainly Administrator should have sufficient privs to see it.

    Perhaps you might do a quick hunt through the html for "sfOpenBrowseAndEditMenuLnk" to see if it's there but being hidden by some CSS conflict ??
  5. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
    24 Aug 2012
    Link to this post
    Well, as I suspected, there is an additional configuration for the inline editing. Wondering why nobody in this forum knew about it... Here it is:
    1. Go to http://yoursiteurl/Sitefinity/Administration/Settings/Advanced
    2.  click 'Pages'
    3. set "Enable in-line editing" to true
    So, in ADDITION to the Permission section, the inline editing option should be configured on the pages level as well. Wondering if it's somewhere in those 315 pages of Sitefinity user's manual and if so, why it didn't come up in the search result page when I was searching for the answer all over the sitefinity site...
  6. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    24 Aug 2012
    Link to this post
    @Inna,

    I think most of us just leave it off... can be a great feature but we're all a tad old fashion

    Jochem
    Answered
  7. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
    24 Aug 2012
    Link to this post
    Thanks a bunch, Jochem, for showing me how to "unlock" this feature. Still, don't get why it's not in the manual... seems like there was no concern about its length. And the feature has been advertised much. Could be as well taught how to make it available....
  8. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    25 Aug 2012
    Link to this post
    @Jochen
    "I think most of us just leave it off..."

    I can't speak for anyone else, but I just left it ON.

    I didn't consider such a setting, because it was enabled by default on my systems.

    However, all of mine have been upgraded from 4.x versions.

    I wonder, has this changed for 5.x installs ?
  9. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    25 Aug 2012
    Link to this post
    @MB,

    No you're right, by default / out-of-the-box it is turned 'on'. 

    Back in the beginning of v4 it had some browser issues and it causes some extra load. So most people I know turn it off when starting development and then 'just leave it off...' 

    Given the fact that browsers seem to span new versions faster than we as dev can keep up with, I'd say if turned on, warn your clients that it may affect their browsing experience...

    Jochem.
9 posts, 1 answered