+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Installation and setup on Windows 8

Installation and setup on Windows 8

3 posts, 0 answered
  1. Nattawut
    Nattawut avatar
    16 posts
    Registered:
    14 Jul 2012
    13 Dec 2012
    Link to this post
    Hi guys,

    I am trying to set up Sitefinity on my laptop running Windows 8 but I have an issue when I try to set up the IIS to run the web.

    When I install the sitefinity which I download from this page: http://www.sitefinity.com/try-now it setup a default project which I can run from web server which comes with "Sitefinity Project Manager". It runs normally.

    But when I start to create a project by select to setup to the IIS (which I previously created a website on IIS earlier). The setup went fine, the tables are created in the database. But when I logged-in to the ~/sitefinity and browse to "Pages" to create/edit pages. It shows the error. (see image)

    I am not sure if the configuration on the IIS is missing or I need to check on anything. But it didn't happen when I do the same thing on Windows 7.

    by the way, Windows 8 come with IIS version 8.

    Any ideas, please let me know.

    Thank you very much in advance.
  2. Patrick Dunn
    Patrick Dunn avatar
    237 posts
    Registered:
    03 Nov 2014
    15 Dec 2012
    Link to this post
    Hello Nattawut,

    Thanks for using Sitefinity!

     Sitefinity does not yet boast full support for IIS8 or SQL 2012. However, we have instances of success. Take a look at this forum post. Namely the last post which discusses ensuring WCF is installed and enabled. It is apparently not by default. Since we use this service regularly it could be the root cause of your issues.

    I hope this helps!

    Regards,
    Patrick Dunn
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Nattawut
    Nattawut avatar
    16 posts
    Registered:
    14 Jul 2012
    19 Dec 2012 in reply to Patrick Dunn
    Link to this post
    Hi Patrick,

    Thank you for the information. I have found what causes the problem which in my IIS hasn't install the WCF by default.

    Thank you very much and best regards,
    Nattawut
3 posts, 0 answered