+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Invalid time zone standard name.

Invalid time zone standard name.

32 posts, 1 answered
  1. Paulo
    Paulo avatar
    19 posts
    Registered:
    03 Nov 2010
    18 Nov 2010
    Link to this post
    Hi

    I was trying the standard version of the RC, and I am having  a "little" problem accessing the web site newly created. It says something about timezone....
    System.ArgumentException: Invalid time zone standard name.

    I live at switzerland and my timezone is   
    UTC +1 : amesterdam, bern, etc....
    System: win 7 professional, 64 bits

    Can you help me on this?

    Thanks in advance
  2. Paulo
    Paulo avatar
    19 posts
    Registered:
    03 Nov 2010
    19 Nov 2010
    Link to this post
    Hi.

    Here is a print screen to help you solve this anoying problem.
  3. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    19 Nov 2010
    Link to this post
    I'm having the exact same problem, any solution?

    /Keivan
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Nov 2010
    Link to this post
    Hello Keivan,

    Could you send us
    ~/App_Data/Sitefinity/Configuration/SystemConfig.config file or paste its content here in the thread.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Paulo
    Paulo avatar
    19 posts
    Registered:
    03 Nov 2010
    19 Nov 2010
    Link to this post
    Hi,

    In my case there is no such file on that path.
  6. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    19 Nov 2010
    Link to this post
    Hi

    It happens even if I start with a new project, the new project doesn't have any files in the directory exept for ProjectConfig.config.

    I'll paste the SystemConfig.config from another project that I've updated from Beta2.

    I'm running +1 Stockholm TimeZone on a Swedish OS.

    /Keivan

    <?xml version="1.0" encoding="utf-8"?>
    <systemConfig>
     <cacheDependencyHandlers>
      <add name="GeneralCacheDependency" description="A generic cache dependency handler." type="Telerik.Sitefinity.Data.CacheDependencyHandler, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" />
      <add name="SecurityCacheDependency" description="A cache dependency handler for permissions." type="Telerik.Sitefinity.Security.SecurityCacheDependencyHandler, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" />
      <add name="PageCacheDependency" description="A cache dependency handler for pages and templates." type="Telerik.Sitefinity.Modules.Pages.PageCacheDependencyHandler, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" />
      <add name="ConfigCacheDependency" description="A cache dependency handler for configuration polices." type="Telerik.Sitefinity.Configuration.ConfigCacheDependencyHandler, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" />
     </cacheDependencyHandlers>
     <systemServices />
     <servicesModules>
      <add name="Search" title="ModuleTitle" description="ModuleDescription" resourceClassId="SearchResources" type="Telerik.Sitefinity.Services.Search.SearchModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
     </servicesModules>
     <controlDesigners>
      <add controlType="Telerik.Sitefinity.Modules.GenericContent.Web.UI.ContentBlock, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" controlDesigner="Telerik.Sitefinity.Modules.GenericContent.Web.UI.ContentBlockDesigner, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" />
     </controlDesigners>
     <applicationModules>
      <add name="News" title="NewsTitle" description="NewsDescription" resourceClassId="NewsResources" type="Telerik.Sitefinity.Modules.News.NewsModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
      <add name="Blogs" title="BlogsTitle" description="BlogsDescription" resourceClassId="BlogResources" type="Telerik.Sitefinity.Modules.Blogs.BlogsModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
      <add name="Events" title="ModuleTitle" description="ModuleDescription" resourceClassId="EventsResources" type="Telerik.Sitefinity.Modules.Events.EventsModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
      <add name="Classifications" title="ModuleTitle" description="ModuleDescription" resourceClassId="TaxonomyResources" type="Telerik.Sitefinity.Taxonomies.TaxonomyModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
      <add name="Libraries" title="ModuleTitle" description="ModuleDescription" resourceClassId="LibrariesResources" type="Telerik.Sitefinity.Modules.Libraries.LibrariesModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
      <add name="Analytics" title="ModuleTitle" description="AnalyticsDescription" resourceClassId="AnalyticsResources" type="Telerik.Sitefinity.Analytics.Server.Infrastructure.AnalyticsModule, Telerik.Sitefinity.Analytics.Server.Infrastructure" startupType="OnApplicationStart" />
      <add name="Forms" title="FormsTitle" description="FormsDescription" resourceClassId="FormsResources" type="Telerik.Sitefinity.Modules.Forms.FormsModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" />
      <add name="Publishing" title="ModuleTitle" description="ModuleDescription" resourceClassId="PublishingMessages" type="Telerik.Sitefinity.Publishing.PublishingModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
      <add name="GenericContent" title="ModuleTitle" description="ModuleDescription" resourceClassId="ContentResources" type="Telerik.Sitefinity.Modules.GenericContent.ContentModule, Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="OnApplicationStart" />
     </applicationModules>
     <smtpSettings />
     <licensing />
    </systemConfig>
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Nov 2010
    Link to this post
    Hi Keivan,

    Could you try to add the following element to SystemConfig.config file

    <uiTimeZoneSettings timeZoneStandartName="W. Europe Standard Time" />

    Please let me know the result.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    19 Nov 2010
    Link to this post
    Doesn't work for me, the same problem.

    /Keivan
  9. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    19 Nov 2010
    Link to this post
    Hi

    If I deply to a Server (IIS) (W2k8 R2 English) with Locale Swedish and TimeZone "Swedish" it works. Don't know what the difference is.

    /Keivan
  10. Giorgos
    Giorgos avatar
    42 posts
    Registered:
    14 Nov 2009
    19 Nov 2010
    Link to this post
    I have also the same problem with Time Zone.............
  11. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    19 Nov 2010
    Link to this post
    Doesn't work whatever value I tried in the uiTimeZoneSettings tag.
    This is true for newly created projects or for Beta2 upgraded projects.
  12. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    19 Nov 2010
    Link to this post
    Hey Keivan, did you try on your US Windows to set Swedish as the Defaul System TimeZone ? My guess is that Sitefinity fails whenever the default TimeZone is non english. But I don't have the time to try that right now...
  13. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    19 Nov 2010
    Link to this post
    Hi Francois

    I'm not sure what you mean, but the server is in production so I can't change any settings, but the server's timezone is Swedish. I tried to change my develop machine that have a Swedish OS to use different TimeZones and also to change Locale and Location, but no luck to get rid of the timezone error.

    /Keivan
  14. Le Corbu
    Le Corbu avatar
    16 posts
    Registered:
    27 Apr 2006
    19 Nov 2010
    Link to this post
    ...also the same problem.....
    just to push priority
    (sitting here in Grmany)
  15. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    19 Nov 2010
    Link to this post
    Ok Keivan, don't change any system settings on your prod server!
    I'll try that this evening if problemn isn't solved by then by Telerik.
  16. Paulo
    Paulo avatar
    19 posts
    Registered:
    03 Nov 2010
    19 Nov 2010
    Link to this post
    Hi,

    I tried all the solutions here, except the systemconfig.config entry (because i don't have the file) and still, have the problem.


  17. Bob
    Bob avatar
    330 posts
    Registered:
    24 Sep 2012
    19 Nov 2010
    Link to this post

    Guys,

    We have identified the problem. It is not the time zone, it is rather localization problem. It happens on some localized Windows versions. We will provide you with a temporary workaround within a couple of hours.  A permanent solution will be available with the next build next week.

    Regards,
    Bob
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  18. RobertZ121
    RobertZ121 avatar
    64 posts
    Registered:
    14 Aug 2006
    19 Nov 2010
    Link to this post
    Hi all,

    I also tried to rebuild the systemconfig.config file by cloning it from a beta-project and replacing the <uiTimeZoneSettings timeZoneStandartName="W. Europe Standard Time" /> .... but nothing new.

    What is now? Another idea?

    Regards robert
  19. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    19 Nov 2010
    Link to this post
    Hey (Telerik) guys I know that you are doing the best you can, but do you have an update for us ? We've been stuck all day long on this issue...

    Thanks.

    François
  20. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    19 Nov 2010
    Link to this post
    Hey everyone,

    You'll get the fix for this (new updated build) Monday.  I was told it's already been addressed, but it's late right now in Sofia.  Building & uploading a brand new build on Friday when everyone is walking out the door is a bad idea.  So we'll get this done on Monday when we have all the people needed to support it.

    Sorry for the slight delay on this.  I appreciate everyone reporting this issue.

    Gabe Sumner
    Telerik | Sitefinity CMS
  21. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    19 Nov 2010
    Link to this post
    Ok, thanks for the update gabe.
  22. RobertZ121
    RobertZ121 avatar
    64 posts
    Registered:
    14 Aug 2006
    19 Nov 2010
    Link to this post
    Hi Gabe,

    this is not good to build a positive relationship. - First we had to wait for the 16th, then the 18th - then it did not work - so I changed my plans and was waiting for the solution as you promised.

    Can we ever relay on that what you tell us???? - So we can go into weekends ful frustrated !!!

    Bad thing.
  23. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    19 Nov 2010
    Link to this post
    Robert,

    If it's truly impossible to wait the weekend, toss me an email to sumner@telerik.com and I'll try to help.

    Gabe Sumner
    Telerik | Sitefinity CMS
  24. Paulo
    Paulo avatar
    19 posts
    Registered:
    03 Nov 2010
    19 Nov 2010
    Link to this post
    Hi,

    Thanks for your effort.

    We will wait paciently.... Have a nice weekend.. 

    Thanks
  25. Haydn
    Haydn avatar
    13 posts
    Registered:
    13 May 2008
    22 Nov 2010
    Link to this post
    Hi Bob,

    Any news on this work around? Will this be resolved in the next release? Note, I have created a brand new project for version 4.0.907.0, and am getting the "invalid time zone standard name" error. The only file that exists in the \App_Data\Sitefinity\Configuration\ is ProjectConfig.config.

    My development machine is running Windows Vista 32bit, IIS7, my local settings are set to New Zealand, but for curiosity sake, I changed my regional date format settings to Swedish, but didn't have much luck getting it running.

    Look forward to the fix

    Cheers

  26. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    22 Nov 2010
    Link to this post
    Hello Haydn,

    We have already fixed the issue in the code. Today, we are going to upload a new build in downloads section of client service accounts, so you will be able to download it.


    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  27. Erik
    Erik avatar
    8 posts
    Registered:
    02 Nov 2010
    22 Nov 2010
    Link to this post
    Hey RobertZ121

    whoever programs without bugs should throw the first stone..........! 

    Do you? Sad, that we have to wait, but shit happens...... 

    You could still work on a template or something else, so no reason to be angry at the developers and telerik, since they are trying their best and trying to inform you about the next steps. 

    Thanks telerik for a great product and great communication! 

    (Mistakes are there to be made!) said by a wise guy ;-)

  28. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    22 Nov 2010
    Link to this post
    Erik, I subscribe to what you are saying.
    It is a problem for me that Sitefinity isn't working as expected.
    But we have to remember that it's still in it's beta phase and guess what, a beta version is expected to have bugs! That is precisely the reason why there is a beta phase: to identify and kill bugs :)

    Thanks to Telerik for your outstanding commitment to you customers and the global quality of your work & efforts.
  29. eb-1988
    eb-1988 avatar
    23 posts
    Registered:
    24 Feb 2009
    22 Nov 2010
    Link to this post
    The new build is online
    Answered
  30. Francois MARTIN
    Francois MARTIN avatar
    29 posts
    Registered:
    07 Aug 2005
    22 Nov 2010
    Link to this post
    Problem Solved.
    "Invalid Time Zone" issue is fixed by the new build.
    Thanks guys
32 posts, 1 answered
1 2