1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Language Pack EN

Language Pack EN

15 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 May 2011
    Link to this post
    Hi there

    I have imported some languages DE/FR/IT after I switch the default backend to EN and the default language for a user to EN some parts of the backend still don't show up in english but in german which I previously set as default.

    To me it seem like I would need to import an EN language pack as well since the Invariant Country no longer works for EN.

    Is this possible?

    Markus
  2. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    19 May 2011
    Link to this post
    Hello Markus,

    Have you tried to restart the application, after you imported the language packs? Also which parts of the backend you see not translated? Is it a dialog ,grid or something else?


    All the best,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    19 May 2011
    Link to this post
    Dear Pavel

    Yes I have restarted the server!

    And its all over the place.

    Again 4.1 fresh install, language packs installed, create second language Front DE, deleted Front EN, Created languages backend de, fr, it. Probably made DE default, changed backend default back to EN

    Updated to SP1

    These are the most likely steps I took if you want to try to reproduce.

    My hottest guess would be that the problem started when I set backend default to DE.

    ---------------
    Where is it happening? All over the place.

    What I would like to try - Import an English language pack. Because Interface an Labels are full in Invariant Country but seem to be empty in English!

    Markus
  4. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    27 May 2011
    Link to this post
    Dear Pavel

    Any news on this matter?
    I think simply importing an EN language pack could fix this problem (at least for me :-))

    Markus
  5. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    29 May 2011
    Link to this post
    Hello Markus,

    It appears that there is some strange behaviour and I'm logging it as a bug. Iimporting English pack could fix some of the issues.

    Best wishes,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    30 May 2011
    Link to this post
    Dear Pavel

    a) where you able to reproduce it in any way?
    b) any chance I can get an EN language pack somewhere :-)

    Markus
  7. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    01 Jun 2011
    Link to this post
    Dear Pavel

    Any answer to my questions above?

    Markus
  8. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    02 Jun 2011
    Link to this post
    Hello Markus,

    Yes, we were able to reproduce the issue and for the English language pack. You can simply export a language pack and then import it for English language.

    All the best,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    06 Jun 2011
    Link to this post
    Dear Pavel

    I was looking for a market place EN language pack solution from your side.

    What I did I exported the invariant language and imported these as english (I am for sure not go to export DE and translate it to english)

    Now the english seems to have some labels but part of backend is still German even though backend language is set default to EN and in my profile I have set the language to EN as well.

    So importing the invariant language as english did not solve my problem.

    ------------
    Can you tell me if there is a fix at the moment and/or if we can expect a fix for this problem in 4.1 SP2 or 4.2?

    Markus
  10. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    09 Jun 2011
    Link to this post
    Hello Markus,

    Part of the problem will be fixed for SP2, but not the whole. For the Q release I hope that we'll have everything in place.

    You can delete App_Data\Sitefinity\GlobalResources folder. This will clean all the imported resources. Then import again the language packs that you need.

    Greetings,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    14 Jun 2011
    Link to this post
    Dear Pavel

    QUOTE
    You can delete App_Data\Sitefinity\GlobalResources folder. This will clean all the imported resources. Then import again the language packs that you need.
    UNQUOTE

    Are you sure this will fix the problem. I am missing EN translation. The imported translations work fine!

    Markus
  12. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    17 Jun 2011
    Link to this post
    Hi Markus,

    This is just going to clean your resources so you'll need to import the English langugage pack too.

    Best wishes,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 Jun 2011
    Link to this post
    Dear Pavel

    Thanks for the feedback. Since my first post from May 17th I am asking if there is an EN language pack. I don't see one!

    So once again is there an EN language pack available somewhere or do I need to create a new project, export the default settings from there and import it in my messed up project?

    Markus
  14. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    23 Jun 2011
    Link to this post
    Hi Markus,

    Sorry, but as I mentioned, the easiest way to get the English language pack is just to export a language pack from your system, the export will generate language pack exactly in English by default. Then just import it for the English language.

    All the best,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  15. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    23 Jun 2011
    Link to this post
    Sorry Pavel

    I was under the impression that if I export a german language pack I would get a german export.

    Since there is no english language by default the only way would have been to export the default. I tried that and imported it as english but the error wasss till there.

    Markus
15 posts, 0 answered